Register | Help | Store Account | FliteTest Dashboard
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
  1. #11
    Skill Collector rockyboy's Avatar
    Join Date
    May 2015
    Location
    Alexandria, VA USA
    Posts
    1,717
    Blog Entries
    2
    Tommy, if it works good for you and you aren't needing some special feature then I'd say there is no reason you need too upgrade. Could come live on the edge anyway though.

    Ben - wow! That's an amazing project! Thanks for sharing!
    The table is my friend. The trees, not so much.

    My hanger listing, build threads, conversion projects, and Taranis radio mods are Over Here....

  2. #12
    Moderator Balu's Avatar
    Join Date
    Feb 2014
    Location
    Münster, Germany
    Posts
    2,871
    Blog Entries
    3
    Quote Originally Posted by rockyboy View Post
    Tommy, if it works good for you and you aren't needing some special feature then I'd say there is no reason you need too upgrade. Could come live on the edge anyway though.
    Living on the edge actually is not only about new features included in an update, but also old bugs being removed. I usually suggest people to update, unless it's a ".0" version number.

  3. #13
    Posted a thousand or more times
    Join Date
    Jul 2015
    Location
    SF Bay Area, CA
    Posts
    1,742
    Blog Entries
    5
    Quote Originally Posted by TEAJR66 View Post
    Wow. Taranis owner for a little over a year now. Still haven't connected it to a computer.

    I am guessing that connecting to a computer is how you copy these files?

    I'm skeerd. It works well as it is. What if I screw something up? Can I brick my radio by connecting it wrong? Can I get corrupt files that have viruses? Will people try to sneak stuff into my radio, like sound effects, when I only want to load a certain model setup?

    Holy Crap!!! I just found a Micro SD Card in my radio! Did I put that there or did it come with it?
    The X9D+ comes with an SD card...The Q-X7 does not and you have to supply one...part of why its cheaper.

    If your X9D+ was new when you bought it you either have OpenTX version 2.0 something or OpenTX 2.1.6 something. The something is because FrSky versions are not identical to the released OpenTX versions...for no particular reason except FrSky stupidity as far as I can tell.

    The main difference between OpenTX 2.0 and 2.1 is a few name changes, Servos became Outputs, and how Telemetry is done. If you do a lot of Telemetry then you probably will want to plan your move from 2.0 to 2.1 carefully. I would upgrade to the latest 2.0 release first. If you have 2.1.6 something then you are already doing Telemetry the new way. If you don't use Telemetry or use it very little then it's not big deal to upgrade to 2.1.9. 2.2 is not released yet so I don't recommend that unless it has something you need.

    You do not need to connect your Taranis to the PC to upgrade the firmware or to transfer other peoples models. You will have to use a PC to get the firmware and to prepare other people's models so you can use them but you can do the firmware and model transfer just through the SD card... it's a lot easier to do directly though.

    However....FrSky screwed up their 2.1.6 release and if you have that and want to upgrade, the first time you do it should be via the SD card. I wrote a procedure for that here not long ago....I'll find it.

    NOTE: In case you get a sudden enthusiasm to do this, do not install Zadig! It has been unnecessary since the X9D+ and OpenTX 2.0 was released. Use the OpenTX Bootloader which does not require any special drivers and is now the preferred method of direct connection for most people.

    The Zadig/STM32 driver method still works and is occasionally useful when things go wrong.

  4. #14
    Fly Angry PsyBorg's Avatar
    Join Date
    Jan 2016
    Location
    Upstate New York
    Posts
    2,839
    Mr Rocky. I dl'd the epee file scanned it and tried to extract it.. says its not a valid file to be extracted... What did I break this time?

    Second. Have you flashed to the newest Open tx yet? I did all the updates recently to get my Alien back in the air. I found that NONE of my model profiles transferred over and were functional. I am in the process of remaking them and have not been able to get the Freerider one to talk to the sim even though I have set the channels to 50% weight and 50% offset.

    The radio is talking to my computer as I have as stated flashed it. It does show the Taranis both as a removable drive (sim card) and the radio (eeprom) so I am pretty sure that is all good. Do you have any trouble with sims IF you have updated to the latest and greatest?
    BILLS LAW: Bils Law specifically states that it covers ANYTHING that Murphy may have forgot, omitted, or plain didn't know in the first place. There fore if it can happen it WILL happen to ME.

    Psyborg FPV You Tube channel.. https://www.youtube.com/channel/UC88...L6-KC9qTa2LgVA

  5. #15
    Skill Collector rockyboy's Avatar
    Join Date
    May 2015
    Location
    Alexandria, VA USA
    Posts
    1,717
    Blog Entries
    2
    I think the answer here is "it's not you, it's me"

    For some reason my %^!%$ home PC has done this a couple time. Spits out a ZIP file that doesn't unzip.

    I'll get this fixed ASAP.
    The table is my friend. The trees, not so much.

    My hanger listing, build threads, conversion projects, and Taranis radio mods are Over Here....

  6. #16
    Fly Angry PsyBorg's Avatar
    Join Date
    Jan 2016
    Location
    Upstate New York
    Posts
    2,839
    No Rush. The real question was about the latest Open tx and whether or not others can no longer set up for flight sims or not.
    BILLS LAW: Bils Law specifically states that it covers ANYTHING that Murphy may have forgot, omitted, or plain didn't know in the first place. There fore if it can happen it WILL happen to ME.

    Psyborg FPV You Tube channel.. https://www.youtube.com/channel/UC88...L6-KC9qTa2LgVA

  7. #17
    Skill Collector rockyboy's Avatar
    Join Date
    May 2015
    Location
    Alexandria, VA USA
    Posts
    1,717
    Blog Entries
    2
    Ahh - I'm running the latest version on my X7 radio and the conversion process was messy as it has fewer physical switches than the X9D+

    I haven't taken the plunge yet to upgrade the X9D+ to the 2.2 release - was going to hold on till a final release instead of the release candidates. Haven't tried connecting 2.2 to a flight sim either. Sorry - not much help on this one
    The table is my friend. The trees, not so much.

    My hanger listing, build threads, conversion projects, and Taranis radio mods are Over Here....

  8. #18
    Fly Angry PsyBorg's Avatar
    Join Date
    Jan 2016
    Location
    Upstate New York
    Posts
    2,839
    Ahh well.. my last battery is on the charger now so real flying will suffice for the day.. I WILL be back tomorrow to pester you again though.
    BILLS LAW: Bils Law specifically states that it covers ANYTHING that Murphy may have forgot, omitted, or plain didn't know in the first place. There fore if it can happen it WILL happen to ME.

    Psyborg FPV You Tube channel.. https://www.youtube.com/channel/UC88...L6-KC9qTa2LgVA

  9. #19
    Skill Collector rockyboy's Avatar
    Join Date
    May 2015
    Location
    Alexandria, VA USA
    Posts
    1,717
    Blog Entries
    2
    Guess what I just saw on an RCG thread?

    https://www.rcgroups.com/forums/show...&postcount=293

    The answer to your sim connection problem

    Looks like it needs to be flashed with a firmware version w/ the mass storage option not-checked
    The table is my friend. The trees, not so much.

    My hanger listing, build threads, conversion projects, and Taranis radio mods are Over Here....

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •