Register | Help | Store Account | FliteTest Dashboard
Results 1 to 6 of 6
  1. #1
    Teaching my son
    Join Date
    Oct 2017
    Location
    Mountain View, CA
    Posts
    8

    DX6 + Timber (disabling SAFE)

    Hi,

    I'm new to forums so forgive me if I'm doing something wrong. :-/

    I have a DX6 transmitter that I purchased 2nd hand and 1.5m Timber. I have control of the flaps and the plane flies great but I have not been able to use a switch to disable the SAFE feature. I followed the instruction in the Timber manual (hold both sticks down and center while flipping the desired switch 5 times) but this does not work. Does anybody have a suggestion on what to do? Do I need to identify a switch in the transmitter so that it transmits that switch position?

    thanks in advance,
    Matias

  2. #2

    Join Date
    Aug 2017
    Location
    Sandy Eggo, CA
    Posts
    104
    Heinrich,

    I just looked over the instructions, and they say to hold the sticks to the bottom outside corners (on the left stick, this would be approx. the 8 o'clock position, and approx. the 4 o'clock position on the right stick) and then flip the Channel 5 switch (which, according to the basic settings, is the Gear1, SAFE/AS3X switch).

    Maybe they've updated the manual since you bought the plane, to make it a little clearer? Not sure....
    Hangar:

    Blade Conspiracy 220, Inductrix Pro, Blade Glimpse, FT Sea Duck

    Workbench:

    FT Duster

  3. #3
    Teaching my son
    Join Date
    Oct 2017
    Location
    Mountain View, CA
    Posts
    8
    sprzout,

    Thanks for that info...I will try what you said tonight.

  4. #4

    Join Date
    Aug 2017
    Location
    Sandy Eggo, CA
    Posts
    104
    Quote Originally Posted by Heinrich View Post
    sprzout,

    Thanks for that info...I will try what you said tonight.
    NP, hope it works for you!
    Hangar:

    Blade Conspiracy 220, Inductrix Pro, Blade Glimpse, FT Sea Duck

    Workbench:

    FT Duster

  5. #5
    Obsession, not hobby TazRC's Avatar
    Join Date
    Dec 2016
    Location
    Phoenix, AZ
    Posts
    297
    Quote Originally Posted by Heinrich View Post
    Hi,

    I'm new to forums so forgive me if I'm doing something wrong. :-/

    I have a DX6 transmitter that I purchased 2nd hand and 1.5m Timber. I have control of the flaps and the plane flies great but I have not been able to use a switch to disable the SAFE feature. I followed the instruction in the Timber manual (hold both sticks down and center while flipping the desired switch 5 times) but this does not work. Does anybody have a suggestion on what to do? Do I need to identify a switch in the transmitter so that it transmits that switch position?

    thanks in advance,
    Matias
    See if this helps: SAFE Select Bind Process Video. The video is with a DX6.
    On the ol' Interweb: tazrc.com

  6. #6
    Teaching my son
    Join Date
    Oct 2017
    Location
    Mountain View, CA
    Posts
    8
    Okay, got it to work.

    I had to set channel 5 to 'GEAR' and then activate by pushing both Tx sticks down and to the center followed by 5x cycles of the switch. The difference was switching channel 5 to 'GEAR'.

    Thanks everybody.

    > Click image for larger version. 

Name:	IMG_20171014_160804.jpg 
Views:	0 
Size:	414.8 KB 
ID:	96329

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •