1. M

    Solved Spektrum Receiver always goes to bind mode

    Hi, I have a spektrum 4649t receiver ( in my new build. When I first powered it up the receiver was automatically in bind mode (rapidly flashing light), this surprised me because it doesn't have an autobind feature like the 4648...
  2. elbro_dark

    Omnibus F4 Pro broken usb port fix with FTDI-Adapter.

    Hi, I broke my USB port on my Omnibus F4 Pro, and i dont know how i can connect the FTDI-Adapter to the board. If i google a How-To i can only find some "normal" F4 boards.:( Here is a Sketch of my board: and here is my Adapter: i hope someone can help me.
  3. Snarls

    Plasmatree PID Analyzer

    If you've been around here a while you might know that I have a love/hate relationship with PID tuning. I spend way more packs tuning than the average pilot these days, but I enjoy getting the most performance out of my builds. It seems that at present, there are two types of pilots; ones who...
  4. ItMightFly

    Looking For FC

    Hey guys! So I have (on accident) bought a SPRacing F3 clone board, and it is very unreliable, very... Ive been looking around the web for a cheap, but realiable, Beta-flight board. I have found a bunch, but very few support Spektrum. The one I found...
  5. Greystarr

    :confused: Quad disarming issues!

    Hi guys, help needed I have an issue with my latest quad. It arms ok Spins props for a couple seconds and then disarms and plays error tones then won't re-arm. Video here Omnibus f4 running betaflight 3.3 Speedix 40 amp 4in1 esc This weirdly seems to...
  6. Snarls

    Control/RX Loss Mid Flight

    Had a few instances today where I would lose control mid flight. One time there was a visible RX Loss warning in the OSD as I loss control. Two other times losing control resulted in a slow flip, but there was no RX Loss warning. Luckily all times nothing was damaged because I was low to the...
  7. 4U2NVME

    FPV with OSD for Fixed Wing

    Hey all, I wish I had people local to ask but as of yet have not run into anybody that is really doing any of this, so I hope the community will have an expert or two to make sure I am going in the right direction. I am wanting to Fly FPV with an OSD, and be able to auto level, or possible...
  8. --Oz--

    Tasmanian Devil plus other tricks - LOS

    Couple of my latest videos, enjoy. my channel
  9. M

    Underpowered Gremlin?

    Hey again guys, more Gremlin problems here. So I just watched the newest FT video, and noticed how much punch the gremlins they were using to race had. Now, mine has no where near that much power. I can hardly get enough altitude to quickly do a flip. Does anyone know why this might be? My...
  10. M

    Gremlin Receiver Issue in Beta Flight

    Hi everyone! I've been having some issues with my gremlin in Beta Flight. I've followed the video build guide very closely, but when I go into the receiver tab, all of the values are at 0. I'm using the same exact receiver as the one used in the build video, and my transmitter is a DX6i...
  11. M

    Problems with Betaflight F4 Flight Controller Built-In Flysky AFHDS 2A Receiver

    Hi, I am building a micro quad, 112 mm. I have a 4 in 1 ESC running, and the FC mentioned in the title. When I go to connect the flight controller to beta flight nothing happens. When I first tried plugging it into the computer, it would work and connect to betaflight. Now, since I have plugged...
  12. R

    How to fly without props || FPV freestyle

    I received a lot of questions about propwash after my last how to tune your quad video. So I decided to make a video on this subject! Hope it can help some of you!
  13. T

    Naze32 Temps are warm when plugged in

    Hey. I'm building my first quad (FT 210 frame) and plugged in my naze and it works fine. I noticed that when I plugged in my Lipo the board gets to around 125 degrees in about 7 seconds before I unplug it afraid that I'm going to fry the board. I have checked that all solder joints are...
  14. D

    SPF3 FC Arming Issue! Halp!!!

    Hey guys / gals! I recently swapped out some parts on my Wizard 220mm frame and am running into an arming issue. I have had a dozen successful flights prior to this and it has me puzzled. I can flash, calibrate my esc's and RC no problem in BetaFlight. While plugged into the USB and on battery...
  15. PenguinWings

    Frsky Gremlin Betaflight Issue

    Hello benevolent Forum Members! I just got finished soldering up an FT Gremlin, but would someone please help me out with the Betaflight setup? It's being uncooperative... I'm using a Frsky XM receiver, so when I configure the receiver in Betaflight, I choose 'Serial Based Receiver' and...
  16. R

    Testing Betaflight 3.2 | Dynamic notch | VLOG #3

    The first release candidate of Betaflight 3.2 has been released just over 2 weeks ago. After hearing so many good things about it, I decided to test it out myself!
  17. S

    Noob that is at a lose with betaflight

    Hey guys, this is my first post after finally joining the hobby after being a fly on the walls for a few years now. I just received the ft gremlin and can't wait to put it together, but I'm having issues flashing the femto f3 board like it shows in the build video. Hopefully you all can help me...
  18. S

    Blade Inductrix Pro Bound but Unresponsive

    Gear: Blade Inductrix Pro - Engineered with Betaflight - (NOT SAFED!!!) Spektrum DX6e Issue: Transmitter binds to Inductrix and arming switch (switch A) seems to respond, but no stick inputs affect behavior. Even in Betaflight, the motors do not correspond to the motor control panel in the...
  19. A

    Help with servo tilt please!!!

    I have a wizard x220 betaflight 3.1.1 and have activated servo_tilt but inorder for that to work I need to remap my output pins in the cli using "resource" but when I type in "resource" it just lists the resources and if I type a command for example: "resource MOTOR 5 none" or "resource SERVO 1...
  20. D

    Blheli Configurator only reading 3 esc's

    Hello, I am as about as new as it gets to mini quad building. I am stuck in the setup phase as I have flashed my kombini fc with betaflight but the motor test slider won't move up at all (safety checkbox is checked). Then I checked BLHeli Configurator and it is only showing ESC 2, 3, and 4. No...