• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Ahhhh ESC/motors go crazy. What is going on?

#1
I just got the Eachine Wizard x220. It has the Spracing F3 Flight controller, now. That said. I got everything set up and ready to go. I turn it on and go to hover, then it insta-flips and goes crazy (never left the ground, though). I had to use the failsafe to get it to stop. So, I checked everything again and retried. Same thing.

I took it back and created a log, calibrated the ESCs. checked the motor numbers, and the motor directions. All were normal. So, I decided to run it from the TX while it was on betaflight. I moved the throttle a little, and saw the problem.

As soon as the throttle goes up, motors 4 and 2 start spinning up to 100 percent, and wont turn off until I drop the throttle to zero.

WHAT IS GOING ON?
 
#2
I just got the Eachine Wizard x220. It has the Spracing F3 Flight controller, now. That said. I got everything set up and ready to go. I turn it on and go to hover, then it insta-flips and goes crazy (never left the ground, though). I had to use the failsafe to get it to stop. So, I checked everything again and retried. Same thing.

I took it back and created a log, calibrated the ESCs. checked the motor numbers, and the motor directions. All were normal. So, I decided to run it from the TX while it was on betaflight. I moved the throttle a little, and saw the problem.

As soon as the throttle goes up, motors 4 and 2 start spinning up to 100 percent, and wont turn off until I drop the throttle to zero.

WHAT IS GOING ON?
Have you tried see what the BL Heli program says your esc's are configured for? Sometimes there can be a discrepancy in betaflight and BH Heli as far as the ECS setup.
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#5
Josh,

The motor tab is showing the values, so stupid or not, the board is driving the ESCs to the severe pitch motion.

That response is either commanded (from your RX) or controlled (from the PID loops).

Take a look at your RX tab and make sure the three directional channels is at 1500 when the stick is centered. If it's not, go into your radio's subtrim (or use the regular trim if it doesn't have that) and adjust it until it's at 1500, and never touch your trim again.

If that doesn't fix it, make sure the self-level modes (angle and horizon) are off and try again. if the craft thinks it's not level, and one of these modes are on, it will keep ramping up the needed correction to get there until those motors are maxed out. This can happen AMAZINGLY fast.

If neither of those work . . . well, we'll continue from there.
 
#7
Ok, I deleted the ranges for all of the preset modes except for ARM, on Aux 2.
All of the values for directions were at 1500.
I watched the motors again, and it shows motors 1,2, and 4 spinning up (gradually) when any throttle is applied. If I drop the throttle to zero, the motors stop. So, it looks like it is trying to correct for something.

If I go back to he Setup tab, and look at the 3d model as I move the drone, the model is wrong. By that, I mean that when I tilt the drone forward, the model does a roll, when I roll the drone left, the model pitches forward. I dont know if ths is the problem; but if it it, I dont know how to fix it.
 

Habakkukk

Fly Eagles, Fly!
#8
On the configuration tab navigate to board alignment (right below motor configuration which is set to "quad x")
Set yaw to 90. Save and recheck the setup page (reset z axis).
If it's still wrong set yaw to -90.
Should fix your issue!
 
#11
I think it is a sensor problem. If I pick it up and tip it in the direction of the motors that are going crazy, then the motors will slow down. Calibrating the sensors should fix it, but it doesnt.
 

Habakkukk

Fly Eagles, Fly!
#12
So motors firing up are normal. It's just trying to compensate but it can't cause motors won't effect anything without props. Your problem from the get go was the board was not correctly "aligned". Leave it at -90 and check your setup tab and make sure the quad mirrors the one on your screen (face the quad forward, hit "reset z axis" and move your quad on all axis.) if it's still backwards switch it to 90, check again, then try 180, check again. Once you confirm your board is aligned properly, throw your props on and go have fun!
 
#14
I tried that. The 90 degree got it facing in the right direction, but the roll and pitch are reversed. I tried changing those around using the degree setting and it didnt change. I dont know how to fix that. On the setup tab, when I pitch forward, the drone rolls right. When I pitch backward, the drone rolls left. If I roll, then it pitches. How do I switch those?
 

Habakkukk

Fly Eagles, Fly!
#15
So the "facing the correct direction" is done by hitting the "reset z axis". I'm assuming -90 yaw is the way to go. Unless you mounted the board upside down? (I believe "roll" is used to offset that.)