• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

APM Mission Planner - Tricopter displays as quad (icon)

Johan

Senior Member
#1
Hi, I'm playing around with the first (and so far only) component for my future tricopter that has arrived through the mail.

It is the APM 2.5.
Now if I upload the arducopter firmware by clicking the tricopter icon, it uploads, but if I then go to Frame Type, I don't see a tricopter configuration, it shows only the following options:

Plus, X and V

FrameType.jpg

Did I miss something?

O, one addition: In the live screen it also displays as a quad

Regards,
Johan
 
Last edited:
#2
My crius board never shows the right thing but it is right in code. Are you using the latest version of both the code on the board and the mission planner?
 

Johan

Senior Member
#3
Hi Kogashuko, thanks for responding.

Yes, the mission planner I just checked. In fact it checks for a new version when prompted and updated today (maybe that is the cause :) ).
Also the board firmware had an update just today, also tried the previous version (I know that is a popular one), but that didn't make a difference.

It seems there is also a 'deeper' firmware for the board itself (there seem to be two levels: the flight config loaded and the deeper board firmware itself, lets call it the arduino firmware).

I haven't tried that upgrade yet (in fact don't know if it is out of date or not:) )

Edit: I should note the previous firmware had distinct versions (Arducopter 2.9.1ib final Tri) and the new one 3.0.1 does not have the Tri mentioned.. But I had the same display with the previous Tri version ....

Kind regards,
Johan.
 
Last edited:
#6
Hi! As far as i know from older versions (2.9.1 was the last i checked) you will have to set and compile on your own copter profile if it's not represented in the Missionplanner. That is normally no problem.
 

Johan

Senior Member
#8
Thanks Crashpilot1000! I was going to have a look in the code anyway, I'm a programmer myself (and curious as well:) )