• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Help! AUX 5 on FRSKY Taranis QX7 going crazy in betaflight.

#1
I'm currently working on a tiny whoop build and aux 5 for my transmitter is going nuts in BetaFlight. I have no Idea why, I've tried flipping all the switches and throttle. Nothing works. If I need to provide more info for people to help solve this problem then ask me. THX
 

ElectriSean

Eternal Student
Mentor
#2
Are you sure you set up the radio properly? Aux 5 in Betaflight is actually channel 9 on the Taranis - Aux 1 is channel 5 (1-4 are reserved for the sticks, the aux channels count up from RC channel 5). Also, by default, none of the switches, sliders or knobs are mapped to channels on the radio, you have to set them up.
 

ElectriSean

Eternal Student
Mentor
#6
Did you test the operation of the arm switch in the betaflight modes tab? The arm mode should change to yellow in the switch position you want it to be armed in. You can (and should) test this without connecting the battery.
 
#7
Did you test the operation of the arm switch in the betaflight modes tab? The arm mode should change to yellow in the switch position you want it to be armed in. You can (and should) test this without connecting the battery.
Yes i did. everything should work but there must be a setting that I am missing thought.
 
Last edited:

ElectriSean

Eternal Student
Mentor
#11
Okay, your arming switch seems to be working fine. The reason the 3D model is slowly rotating in Betaflight is you don't have your transmitter's subtrim correctly adjusted. You should adjust the subtrim (on the outputs page on the Taranis) so that the sticks center at 1500. You should also adjust the servo travel (also on the outputs page) so that the sticks are at 1000 minimum and 2000 maximum. Use the receiver tab in Betaflight to see what the FC sees. There are tons of videos on YouTube that demonstrate this procedure. After you get that sorted, just try to hover while disconnected from the computer.
 
#12
Okay, your arming switch seems to be working fine. The reason the 3D model is slowly rotating in Betaflight is you don't have your transmitter's subtrim correctly adjusted. You should adjust the subtrim (on the outputs page on the Taranis) so that the sticks center at 1500. You should also adjust the servo travel (also on the outputs page) so that the sticks are at 1000 minimum and 2000 maximum. Use the receiver tab in Betaflight to see what the FC sees. There are tons of videos on YouTube that demonstrate this procedure. After you get that sorted, just try to hover while disconnected from the computer.
ok thanks I will try it soon
 
#13
So after doing everything u told me, I disconnected it and now it just goes straight up and spins counter-clockwise like mad. I can try to combat the spinning but it just goes up to the ceiling to fast. The throttle almost seems unresponsive.
thanks for all your help!
 

ElectriSean

Eternal Student
Mentor
#14
Very strange... If you have air mode enabled as a feature, disable it and enable motor_stop. This will stop the props at zero throttle. Then try arming and slowly increasing the throttle to get to a hover. If it still takes off into the ceiling, try dropping the Proportional values in the PID tab by half.
 
#15
Thanks for being patient with me! I tried putting the Proportional values by half and that helped the problem a bit but it still takes off and goes where it wants.
 

ElectriSean

Eternal Student
Mentor
#16
I've never seen a quad just try to take off and escape like that... Were you mean to it? lol...

Can you post some screenshots of your configuration, receiver and PID tabs?