• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Balsa Baby Baron

Jackson T

Active member
#61
Ouchhh! That hurts just looking at it. What radio are you using? Sounds like you need you need a new one. Good luck getting that fixed, might take awhile :confused:, I’m sure you’ll do it though;).
I'm using a new TX6I from OrangeRx. I'm thinking I might have got a dodgy receiver (also OrangeRx). This isn't the first time its needed major repairs. I folded the wings on the high start once. Yeah, I was pushing it too hard!
 

Bricks

Well-known member
#63
Not sure how the TX6i is set up for transmitter antenna if it is a single antenna straight out the top the worst thing you can do is point the transmitter at the plane.
 

Jackson T

Active member
#64
That would tick me off. Did you say you just got that radio? Hope the place you bought it doesn't give you grief when you return it.
Hobbyking is happy to give me a new receiver, but the one I got is out of stock so they probably won't be able to send me the replacement until Feb or so.
Not sure how the TX6i is set up for transmitter antenna if it is a single antenna straight out the top the worst thing you can do is point the transmitter at the plane.
Good point! I will have to ask Hobbyking. I'm not certain, but I'm pretty sure I had the transmitter pointing in relatively the same direction the whole flight. This time and a few previous times I fly quite far away from myself (~600m or 2000ft), then turn around and it cuts out when I'm around half way home.
 

Jackson T

Active member
#65
I FINALLY maidened it! It was a bit of a handful because it's got full span ailerons and no dihedral, but it flies! Sorry for the massive delay, but I've only just finally sorted out all of my technical difficulties. Guess what this means? Time to build the next plane!

P.S. I have maiden footage (not very good quality though), but I'm having trouble attaching it. How do you guys normally attach your vids?
 

DamoRC

Well-known member
Mentor
#66
I FINALLY maidened it! It was a bit of a handful because it's got full span ailerons and no dihedral, but it flies! Sorry for the massive delay, but I've only just finally sorted out all of my technical difficulties. Guess what this means? Time to build the next plane!

P.S. I have maiden footage (not very good quality though), but I'm having trouble attaching it. How do you guys normally attach your vids?
I don't think you can attach vids directly. Normally you upload the vid to YouTube or other video hosting service and then you can insert the link to the video inyour post (use the insert media option using the "..." button.

Look forward to seeing this in the air. What airfoil did you use?
 

Jackson T

Active member
#67
I don't think you can attach vids directly. Normally you upload the vid to YouTube or other video hosting service and then you can insert the link to the video inyour post (use the insert media option using the "..." button.

Look forward to seeing this in the air. What airfoil did you use?
Ok, so that would mean I would need a YouTube channel, doesn't it? I just used a basic flat bottomed aerofoil off an old free flight glider that I've had success with in the past. Just like all my planes, I'm way too freaked out to go to full throttle on it because of its 2-1 thrust to weight ratio. If I ever did, I recon it would be faster than my FT Arrow!
 

nhk750

Aviation Enthusiast
#68
Nice, glad to hear it flew well. My Extra 300 build is almost done, but is on hold now as we are moving in a while....
 

Jackson T

Active member
#75
You should be. It looks great. Get it up on Youtube so we can see her fly! What was the solution to the radio issues?
Thanks! I'll have to ask my parents about getting a youtube channel. The solution to the radio problem was that the first 2 receivers were duds. I finally got the third one after a rediculously long wait for each replacement. At least this one works!