• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

BeeBrain Flight Controller & BetaFlight - Input Delay

#1
Hello FT community, I just built my first quad and am having a few issues I don't know how to fix. The first being a pretty large delay between my transmitter and my quad. I'm using beta flight and a bee brain flight controller with a DX6. I'm not sure what setting will lower that delay. Also, I have my motors set up to where they don't spin up once the quad is armed. This works for the most part, except when I enter acro mode they spin up and when I cut throttle they don't cut out. When I cut my throttle, I want my quad to fall, not glide. Lastly, my acro mode doesn't quite stay where it should be, it slowly drifts back to center instead of staying in it pivoted angle.

I know this is a lot of issues, but I'm new to the whole building/setting up your own quad. However, that's why I came here! a place I know where I can get help.

Fly safe Out There,
Sam
 

makattack

Winter is coming
Moderator
Mentor
#2
I would double check your settings because it doesn't sound like things are correct. Hard to troubleshoot without the configuration itself. If you want others to look at it, I suggest either getting a configuration dump (via the CLI) or screen shots of the configuration and mode settings.

Do you see these delays on the RC input screen on all the channels and any stick movement?
 
#3
I would double check your settings because it doesn't sound like things are correct. Hard to troubleshoot without the configuration itself. If you want others to look at it, I suggest either getting a configuration dump (via the CLI) or screen shots of the configuration and mode settings.

Do you see these delays on the RC input screen on all the channels and any stick movement?
There is no delay on my DX6, only on he quad, I'm thinking maybe the gyroscopes refresh rate needs to be bumped up. Right now it's at 1 kHz, and I'll post a picture of my settings in this response. The spin up throws me off because I have angle, horizon, and air modes. However, only on Acro does it spin up when armed even though it's off.

(My phone isn't letting me upload pic I'll do it on my PC in a minute)
Roll: PROPORTIONAL - 80 INTEGRAL - 40 DERIVATIVE - 35 RC RATE - 1.0 SUPER RATE - .77
Pitch: PROPORTIONAL - 90 INTEGRAL - 40 DERIVATIVE - 35 RC RATE - --- SUPER RATE - .77
Yaw: PROPORTIONAL - 180 INTEGRAL - 45 DERIVATIVE - --- RC RATE - 1.0SUPER RATE - .80
 

makattack

Winter is coming
Moderator
Mentor
#4
That explains a bit more... You have airmode programmed with acro... if that's the case, those motors can spin up randomly. Soo... I would recommend airmode be on a separate switch and don't enable it until you're actually in the air, and make sure to turn it off if you're not in the air.

If you are in angle mode, it may be a bit sluggish if you haven't tuned the PID's to your frame/electronics. Those look like default rates. You don't like the pitch RC rate, so ... that could be wrong if it's not 1.0 or higher. The super rate could be bumped up if the expo is too high on that... I recommend watching some videos about betaflight PID tuning and RC rates.