• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Betaflight 10.6 seems to have omitted something...

Thorondor

Active member
#1
I upgraded my Betaflight configurator to 10.6 and flashed my board to 4.1 recently, and "Flip over after crash" mode has disappeared from the Modes tab. Did it get relocated or did I screw something up?
 

Thorondor

Active member
#5
Your ESC's are fine, but perhaps the default ESC protocol changed between versions. Turtle mode requires DSHOT. If it's not enabled, the mode is not available.
Would I be risking anything like burning the ESCs by changing the protocol from the default? Keep in mind I changed to 48MHz, but other than that I haven't changed any firmware.
 

ElectriSean

Eternal Student
Mentor
#6
Would I be risking anything like burning the ESCs by changing the protocol from the default? Keep in mind I changed to 48MHz, but other than that I haven't changed any firmware.
No, worst case is the anti-taz will disarm for you if it freaks out, or it will just beep at you. What ESC's are you using? The specs for them should tell you what protocols they support.
 

Thorondor

Active member
#7
No, worst case is the anti-taz will disarm for you if it freaks out, or it will just beep at you. What ESC's are you using? The specs for them should tell you what protocols they support.
I'm using the Crazybee F4DX board that's stock on the Mobula7. The ESCs are built into the board I think.
 

ElectriSean

Eternal Student
Mentor
#10
Why would the configurator change the default ESC protocol? That doesn't seem like something that should be changed lightly.
I'm not sure why it would change. I believe the defaults are setup in the target file, so it probably changed when you flashed. Defaults are usually set to work with the lowest spec hardware. It's not a big deal in terms of damaging equipment, and it one of the things you should check/configure after flashing.
 

Thorondor

Active member
#11
I'm not sure why it would change. I believe the defaults are setup in the target file, so it probably changed when you flashed. Defaults are usually set to work with the lowest spec hardware. It's not a big deal in terms of damaging equipment, and it one of the things you should check/configure after flashing.
Would you happen to be available to help troubleshoot something? I changed the protocol from ONESHOT125 to DSHOT600 and now my motors won't spin when armed. Betaflight shows them spinning on the workbench, but they don't actually spin. When it runs off of a flight battery, the flight mode is shown on my OSD but the motors get no power. I tried changing the protocol to all of the options including the original one, but none of them work.
 

Thorondor

Active member
#12
Would you happen to be available to help troubleshoot something? I changed the protocol from ONESHOT125 to DSHOT600 and now my motors won't spin when armed. Betaflight shows them spinning on the workbench, but they don't actually spin. When it runs off of a flight battery, the flight mode is shown on my OSD but the motors get no power. I tried changing the protocol to all of the options including the original one, but none of them work.
Nevermind, I figured it out. Apparently when you switch to 48MHz you have to increase the ESC startup power in BLHeli. I changed it from 0.50 to 1.00 and the motors work fine now.