• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Betaflight, Airmode, Channels, Rates, Oh My!

#1
Just when I think I've sort of figured something out I find out just how deep the rabbit hole goes! Things that keep my awake at night...

Betaflight... I know when you select your board for new firmware it only gives you options that are compatible with your board, or are they? I flashed a new version of Betaflight to one of my boards and all sorts of weird stuff is happening now. I've never used Airmode, but some of the symptoms of weirdness sound like what happens if Airmode is on (like motors spooling up even though very little throttle input is given - Acro on, Airmode off, props on/off).

Speaking of Airmode, I'm excited to try it. As well as tuning a bit to see if I can find some PID settings that match my flying (like smoothing out some of the responsiveness from the quad - everything now is jerky and abrupt).

Also for Airmode, how do you tie it into one of your channels to be switched on? I don't really use angle/horizon so I guess I could use that channel. My other channel is arm/disarm. Otherwise I guess I would need a TX with more than 6 channels?

Currently I'm not a happy flyer as the one board, SirinFPV, is having the motor issue (which I'm knee deep in fixes/tutorials trying to sort out) and the other a IRCFUSIONF3 having constant firmware flashing timeouts and bootloader fails (few times I can get it to connect I get no input from the TX).

Ramblings over!
 
#2
assuming you are on the latest version of betaflight. airmode is set to always on by default. this is set on the configuration tab.
as for creating switches try this video

dave
 

PsyBorg

Wake up! Time to fly!
Mentor
#3
Thanks Dave. I know now to look for that if and when I update BF.

For my quads I set a 3 position switch for modes like this. Pos1 is horizon mode. Pos2 is acro mode. Pos3 is acro with airmode.

Airmode on full time for new pilots is not a good idea. When it comes to landing if airmode is active and you land hard airmode can kick in and toss the quad back in the air in a random direction.

Also being new save pid tuning for when you understand what they do and how to manipulate them. You can easily burn out electronics if you dont.

What you want to do is lower the rates to make the quad more docile.
 

FDS

Well-known member
#4
I had no problem with airmode, it was more of a problem when my motors cut right out when I dipped the throttle with it off. Watch Bardwell’s landing video, end bouncing for good.
I still leave Pids alone, my brain hurts enough already without adding that.
I can thoroughly recommend lowering your rates and adding some softer crntering to your sticks through rate tuning, my flying was transformed by that, it made me much smoother and less scared especially in acro. Again Bardwell has a great rates video, I found that gave me a good start in setting it up.
I have stayed on Betaflight 3.5-3.7 so far, left 4.0 alone.
I stuck to FC boards with lots of documentation and set up videos so it was simple to get going. It was worth a little extra upfront cost. If you are going to use F3 boards then expect them to be harder to set up as they are effectively obsolete, betaflight beyond 4.0 won’t support them. F4 boards are cheap enough now that they should be your minimum IMO.
Also save your factory defaults and CLI dump BEFORE you flash anything.
 
#5
should mention the airmode always on can be turned off. i set mine up like psyborg's with the "always on" feature turned off.
didn't think to ask what radio you were using. that vid applies to frsky radios.
@psyborg,i thought you were on BF???
 
#6
Rates! I'll do my research and leave the PIDs alone for now. Also the switch setup sounds good for my 6 channel tx (Spektrum DX6e).
Pos1 is horizon mode. Pos2 is acro mode. Pos3 is acro with airmode.

What you want to do is lower the rates to make the quad more docile.
 

PsyBorg

Wake up! Time to fly!
Mentor
#7
should mention the airmode always on can be turned off. i set mine up like psyborg's with the "always on" feature turned off.
didn't think to ask what radio you were using. that vid applies to frsky radios.
@psyborg,i thought you were on BF???
My Alien and Taz are full KISS builds. The new Mach1 and my Gremlin are on Betaflight.

My FT Versacopter was on Cleanflight hehe
 
#8
Yet again, another hurdle.

I've got a quad that wobbles.

*** Just realized when I installed a new RX it's larger than the previous one and my board was no longer floating, but had some pressure from the frame pushing down on the RX. Did a test removing the top plate and relieving the pressure.. no more wobble. The RX has a plastic case, I'll remove it from the case and find a spot inside where it can gentle sit.

***No luck, it flew great without the top plate off, but as soon as I attached the plate back it resumes the wobbling.

Fixed below - I guess it was flying smoother without the added weight, and could correct - even though the alignment was incorrect?
 
Last edited:
#9
Solved the wobble:

Board and Sensor Alignment> 225 Yaw Degrees (As my board is mounted 45 angle). Previous I thought I had this set at 180 but this setting made everything appear to be in order within Betaflight - but now I see it was slightly off and was causing the drone to try to correct while in flight.