• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Betaflight Arm Switch Issues

#1
Hey

My TX is bound, everything is fine in receiver tab on Betaflight, and my angle/horizon/acro mode switch is good and working, but when I try to arm, the 'arm' text isn't glowing orange to show that it is working. The other switch is functional, as the screenshot shows, but the arm isn't working?

Does anyone know how to help? It would be very much appreciated.

Harry C :)
 

PsyBorg

Wake up! Time to fly!
Mentor
#4
Hopefully the Video helped you sort it all out.

I set my switches slightly different. First there is no reason at all to use angle mode.. It is the same as horizon mode only less adaptable.

I use a three way switch above my right stick to arm where it has to be pulled down twice to arm. That way if it gets bumped it won't arm on one click. Then I set up another three position where the o position is Horizon mode, position 1 is Acro mode ( for take offs and landings and racing.) and position 2 is Acro with Air Mode for Freestyle flying. Finally I have a third three position switch for Radio light off, Radio light on, and beeper for lost model alarm.

modes small.jpg
 
#5
Same issue

I am having the same issue with my new build, channel mapping is set and all seems normal.
Only thing I can’t do is Arm, AUX1 is set and the slide moves to arm but the arm box dose not light yellow (typical indicator)
Air mode lights ,beeper lights fine.
Was hopping you figured out what was causing this!!
 

ElectriSean

Eternal Student
Mentor
#6
I am having the same issue with my new build, channel mapping is set and all seems normal.
Only thing I can’t do is Arm, AUX1 is set and the slide moves to arm but the arm box dose not light yellow (typical indicator)
Air mode lights ,beeper lights fine.
Was hopping you figured out what was causing this!!
The answer will be in the video linked above.
 

ElectriSean

Eternal Student
Mentor
#8
Newer versions of BF won't arm while connected to the GUI unless you go into the motors tab and tick the box that asks you to make sure the props are off. If that doesn't solve it, go into the CLI tab and enter the status command - this will give you whatever flags are preventing arming.

 
#9
Newer versions of BF won't arm while connected to the GUI unless you go into the motors tab and tick the box that asks you to make sure the props are off. If that doesn't solve it, go into the CLI tab and enter the status command - this will give you whatever flags are preventing arming.

ticked the safety tab and the motors wont run from tx or from gui. only prevention flags are the two most common related to being connected to the GUI. Is a PREARM needed if ARM is already set?
 

ElectriSean

Eternal Student
Mentor
#10
I'm pretty sure the prearm is only active if you have that mode set up, but I've never played with that. Your motors won't run from the motors tab either? Do they beep when you plug in the battery?
 
#11
I'm pretty sure the prearm is only active if you have that mode set up, but I've never played with that. Your motors won't run from the motors tab either? Do they beep when you plug in the battery?
I don't understand it wither. i get the usual warm up beeps when I plug in the battery. A red light blinks when I raise the throttle and goes away when I zero it out. I'm still not getting any RSSI values either.
 
#13
The protocal im using now is DSHOT600 the one that comes with the emax tinyhawk cli dump, but I will go ahead and test that. Also, no matter how many times I disable prearm, it shows up in my modes tab when I reconnect the drone.
 
#14
FINALLY resolved!! when betaflight is fullscreened on my pc, it doesnt show the save button at the bottom. I was going into CLI to save my modes AFTER deleting prearm. I just happened to try minimizing the window and was able to scroll all the way down to save. just got in a new caddx camera as well! Thanks again for taking the interest and offering your knowledge! :) :)
 
#16
Had me stumped for a while too. New Betaflight feature showing "Arming Disable Flags:" proved quite helpful. Indicated throttle too high, Rx tab showed it at 1050. My endpoints were off. Went to settings on my Spektrum Tx> control setup> lowered the ALT setting by the 50 points it was off by. Voila.

Video below helped me (visually).

End points Spektrum Betaflight

Also: https://oscarliang.com/quad-arming-issue-fix/
 
Last edited: