• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Betaflyght selectors problem.

#1
Hi, I would like to ask for help, I was finishing programming the drone with Betaflyght, and then I noticed that in the page of the radio transmitter (with the latter, always connected to the drone and connected to the PC), the selectors it do not see them, only hear them the two joysticks, in fact their values change, but from AUX 1 to 11 no and I don't understand why ... Can anyone help me?
Cattura.PNG
 

FDS

Well-known member
#2
Have you set up the correct receiver UART in the Ports tab?
Do none of the channels move when you operate the sticks?
Some receivers only work when the main battery is plugged in. Remove the props, then plug a battery in and check again.
 

ElectriSean

Eternal Student
Mentor
#3
What radio are you using? Many (especially Taranis) don't assign aux channels to switches by default, you have to set that up in the radio first.
 

FDS

Well-known member
#4
Ah, it’s a problem with switches!
See above, you need to set up your input screen with sone switches for arming, flight modes, buzzer etc.
If you are not using Open TX there will be an “assign switches” screen on your transmitter.
Project Blue Falcon has a great video on setting up modes etc here-
 
#9
Guys, I need help, for many weeks I tried and tried again, but I couldn't solve my problem with Tiny x6 and Taranis Qx7, they communicate with each other, in fact when I connected them to the PC (Betaflight), the parameters varied. .. But when I try to make it fly the engines don't turn, but radio command and receiver communicate ... is it possible that I forgot to activate something?
pls pls pls
 
#12
Looking at the screen shot of betaflight in first post I see several issues.

It does not look like you set up centers and end points in the radio, done a gyro and accelerometers calibration and I sus pect the main issue to be improper channel order. It seems what is labeled as gas (throttle) is sotting at center of range which will not allow the quad to arm.

Set your channel centers and end points properly and pay attention to what stick moves what axis in betaflight. My guess is that needs to be changed to TAER not AETR as it is currently set.