• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cannot connect to BLHeli (but I can connect to BetaFlight)

I am trying to get my new Gremlin setup. This is my second one (first crashed/destroyed). It has the new FC and 4-in-1 ESC (https://store.flitetest.com/flite-test-fullspeedrc-flight-controller-4in1-esc-stack-flt-3055/p873734 ). I can connect and have everything setup/configured in BetaFlight (Firmware v 3.4.0). Now I need to reverse a couple motors, and I cannot get BLHeli to connect using stand alone app (Running - OS: Windows, Chrome: 63.0.3239.108, Configurator: 1.1.0 ).

Here is the log from BLHeli:

2019-05-05 @ 13:36:31 -- Serial port successfully opened with ID: 1
2019-05-05 @ 13:36:32 -- MultiWii API version received - 1.39.0
2019-05-05 @ 13:36:34 -- Flight controller info, identifier: BTFL, version: 3.4.0
2019-05-05 @ 13:36:35 -- Running firmware released on: Jul 8 2018 04:23:43
2019-05-05 @ 13:36:36 -- Board: OMNI, version: 0
2019-05-05 @ 13:36:37 -- Unique device ID received - 0x1c00215734570120363930
2019-05-05 @ 13:36:41 -- Connection failed, ensure that you have selected the correct port or restart your device.

I tried BLHeli_32 thinking perhaps it's a 32-bit processor on those ESCs (no documentation could I find anywhere for this board - very very frustrating!!). It can connect, however it throws an error when i click "Check" ("Found no valid ESC configuration", so thinking these are not an 32 bit ESCs.

I have tried to connect with the quad's battery plugged in, and without. I have connected the USB without to the battery, then plugged the battery in, then tried to connect. I have tried both the above with and without my transmitter on. I have spoken nicely to it. i have screamed at it.

I am hoping one of you can help me so I can get my new bird in the air!
I tried the Chrome version of BLHeli. I get the same error.

I guess it's time to swap some wires, but would still like to know why I cannot connect if anyone has any other ideas. Thanks


Wake up! Time to fly!
Specs say the esc runs blheli s flashed with 16.6 firware. This requires the chrome app to work with the esc.

You plug your flight controller into ypur computers usb. DO NOT connect to Betaflight. Start the chrome app and connect. You wont be able to read or write to the esc until you plug in the flight battery. MAKE SURE PROPS ARE OFF before connecting the battery.

Once it all boots you read the esc configuration THEN you can make changes to the esc. Be sure you write the changes to save them.

I always do a full reconnect and check the changes I made actually are in effect before putting props back on and test flying
I had enough trouble with Betaflight, getting more trouble with BL Heli was not my idea of fun. Swapping two wires was dead easy and didn’t require me learning or messing up a whole new program!
Indeed FDS; That is what I did, and the little fella flies Great!


Elite member
@kDub-Racer I am not the most technical builder here, in case you haven’t noticed that yet!
That’s what I like about here vs other forums, nobody judges you on how you fix stuff, they just offer you a range of advice and what has worked for them, then if you screw it up they try to show you where you went wrong rather than judging your work. If it’s dangerous then people will point that out and give good safety tips without making you feel like a total noob. It’s really helped me navigate my first three quad builds.


Wake up! Time to fly!
As Caroline said its right there in the link you posted.

Most respectible vendors will post specs and some even do recomended set up tips lower on the page once you get past the hype sale schpeel and beauty shots of their gear. 😁