• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't connect to betaflight when battery is connected to quad

#1
Hi I just bought and built my first quad but am having trouble connecting to betaflight. It connects just fine when it is only pluged into the usb but if the battery is plugged in it doesn't connect. I'm using the mamba f405 mk2 stack and ive tried everyting i can think of. I've flashed the board, tried on different computers, tried different usb cables, etc. Any ideas why? Any help is appreciated.
Thanks
 
#6
What are you trying to set up the receiver for? To my knowledge beta flight is not used to set up receivers, like I said though, I am a noobie with beta flight.
 
#7
Well because im using flysky with ibus its a bit more finiky and i cant tell if the fc is recieving the data from the transmitter. Im also having some other problems and it makes it a lot harder to trouble shoot things like arming if i cant tell if the fc is recieving suff
 
#8
Yes, BetaFlight should stay connected when you power by Lipo. Otherwise you would not be able to test motors or receiver settings.

Are you using the latest version of BetaFlight Configurator? Is your arming switch set in the modes tab?
 
#9
BetaFlight version 3.3 or higher prevents arming when connected by USB, but does not limit the FC from being otherwise powered by lipo while simultaneously being connected to a USB cable and BetaFlight.

That makes me wonder about a few things in relation to Flysky. First, verify your receiver is connected to correct pads on the FC. Also, is the FC new, or has it been in any way damaged? I am wondering about a short in the USB connector.
 
#10
I am using the latest version of betaflight and i bough the fc new of banggood a couple weeks ago and it doesn't seem to get overly warm when its plugged in. Because the flysky reciever doesnt use sbus (it uses ibus) I cant put the data cable on the sbus pad so i put it on the rx 6 pad because a some forum post said that that worked for them but i also had it on rx 3 and it didn't solve anything.
this is the fc pad map if it helps:
https://cdn.shopify.com/s/files/1/0...-2a0b-4693-8104-94b9e77468e4.jpg?v=1577331450
 
#11
That Mamba board is a good one, and moving the RX signal wire to rx6 seems like the right step. If the quad powers up with battery (and no smoke), and the FC connects to BetaFlight via USB without battery it may have nothing to do with your RX soldering. I don’t know anything about FlySky, but maybe you can post a screen shot of your BetaFlight Configuration, Receiver, and Modes tabs.

Also, the Mamba ESC expects 6s voltage - it is possible that if you connect anything less, it will not correctly regulate the FC 5V pads.
 
#12
It powers up fine but doesn't arm which i think has something to with reciever not transmitting properly. Because the receiver isn't powered when the battery isn't plugged in. I know it can take 6s but im using 4s and it should be able to go as low a 3s but i haven't tried that.
Here are my screen shots:
This is how the ports are set up
Ports tab.png

The only things I have changed in the configurations tab is that I changed is changed the type of serial reciever im using from Sbus to ibus
Configurations tab.png

And the reciever tab never reacts even when the reciver is conected to the transmitter
Reciever tab.png
 
#13
Those tabs all look good so far, what about the Modes tab?

Also, normally, when an ESC supports a different battery cell count, it will say "3-6s" - this one says only "6s" - try a 6s battery.
 
#14
I'm pretty new to the hobby so i don't have any 6s battery's cause i was only planning on using it with 4s. I could but two 3s battery's in series but i don't know if that would be a good idea.
Anyway, here is the modes tab. This is the only one which seems of because it says its disabled even though i don't know how to enable it.
Modes.png

Thanks for all the help so far aswell :)
 
#15
In the modes tab, the Arm switch, what UART did you select? It appears that you may have selected a UART that is already in use (hence the red).
 
Last edited: