• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cant get my FPV setup to work :(

Jordie

Junior Member
#1
Hi,
I'm started to feel a little frustrated and that I have wasted my money due to wiring up all my fpv gear and getting nothing, hoping someone could please help.

Here is what equipment I have:

TX&RX:
http://eu.banggood.com/Wholesale-Wa...smitter-Receiver-TS832-RC832-wp-Uk-84771.html

Camera:
https://www.buzzflyer.co.uk/product...&strPageHistory=search&numSearchStartRecord=1

I connected the camera and transmitter fine and am using a 3s 1000mah lipo for both. For the receiver I'm using a 2s 1000mah lipo.
When connected to my display, I get audio from the built in mic on the transmitter, but no video at all, when feeling the camera, it does feel warm so there is defiantly power going to it, but nothing on my display :(

Any help is very appreciated.
 
#2
Can you post some pictures? It would be much easier to help you, if everyone can see the set-up.

EDIT: It looks like the receiver power input is 12V. A 2S battery will not work with it.
 
Last edited:

SHIFFTY

Junior Member
#3
so i am having some fpv gear issues myself! i hoked it all up and did a testing on my friends 50" TV everything worked great! went to the goggles and the screen goes snowy when i throttle up? have full batteries and changed no settings from the tv to the goggles? have tried every channel on the tx and every channel on the rx as well and just snow when i take off. not sure what to do or think.
 

makattack

Winter is coming
Moderator
Mentor
#4
SHIFFTY, You may need a LC Filter such as these:

http://www.getfpv.com/lc-common-mode-power-filter.html
http://www.readymaderc.com/store/index.php?main_page=index&cPath=11_66_71
http://www.hobbyking.com/hobbyking/store/RC_PRODUCT_SEARCH.asp?strSearch=power+filter

Or you can make one yourself:
http://blog.oscarliang.net/lc-filter-fpv/
or a fancier version:
http://blog.oscarliang.net/power-filter-video-transmitter-fpv-camera/

For Jordie,

You definitely need to post some detailed/close up pictures or descriptions of your wiring. My guess, if the equipment works, is a bad connection.
 

SHIFFTY

Junior Member
#5
Makattack, thank you.. i have a filter on it already for that reason of the dirty dc power. but its odd to me that it worked great on the tv set and i was indoors and the quad was outdoors! and had great signal and great picture but when the goggles are hooked up as soon as i throttle up to take off the screen goes to snow? i just don't get it.
 

SHIFFTY

Junior Member
#7
i think i figured it out peeps!

I was having this same problem, but a comment on the Hobbyking website pointed me in the right direction. If your tx/rx system has Audio, do NOT connect the audio input to the Quanum. Both inputs on the Quanum are for video (why??) and when you hook up the audio channel to the 2nd video input it causes the interference.

who would've guessed both lines are for video
 

makattack

Winter is coming
Moderator
Mentor
#8
Ah, glad you figured it out. Yeah, strange they even include an audio line, as I suspect the monitor doesn't even have a speaker. Even weirder is that both lines are connected to each other -- unless it's to make it easier to connect things. You can use either plug sort of an idea. Still, it's a strange idea.

Actually, now that I think about it more, this could be a cheap "video out" port... but clearly, they didn't document it as such.
 

SHIFFTY

Junior Member
#9
Ah, glad you figured it out. Yeah, strange they even include an audio line, as I suspect the monitor doesn't even have a speaker. Even weirder is that both lines are connected to each other -- unless it's to make it easier to connect things. You can use either plug sort of an idea. Still, it's a strange idea.

Actually, now that I think about it more, this could be a cheap "video out" port... but clearly, they didn't document it as such.
yeah talk about making a poor guy confused as all get out! :eek: thinking he has everything all wrong and mad a mess of things. just didn't make scene to me at all till now. thank you for your help tho i was ready to give up and sell the whole thing!