• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DX6 Differential Thrust problems

whackflyer

Well-known member
#1
Hey guys,

Recently I've been building and setting up a twin cargo plane of my own design (twin c pack), and now I've got to the electronics part. That's where I'm having problems. When I go into the mix menu on my DX6 and try to do the rudder plus Aux1 mix for differential thrust (like the FT article says to do, link below), I only have the option of gear and no Aux1 option. I don't have flaps set up so that's not the problem. Any help of how to get this solved would be greatly appreciated. Thanks!!!

https://www.flitetest.com/articles/differencial-thrust-setup-on-a-spektrum-dx9
 

Merv

Well-known member
#2
The any free channel of your Rx should work just fine. The idea is to have each motor on it's own channel. Have the throttle control (master) both, in the same direction. The rudder should make one channel go higher and the other lower.
 

whackflyer

Well-known member
#3
I just tried it with the gear channel, and then it will only give me the option of the Aux1 channel and not the gear channel. Has anyone else had any problems with this or am I the only one to ever have this problem?
 

whackflyer

Well-known member
#5
Yes I have. The first mix (step 6) of the article is where my TX won't let me assign the right mix. I can choose rudder for the master but when I try to select a slave channel it has all 5 channels available except Aux1 which I need to use. It's just opposite when I try to use channel 5 for the second esc, as in when I try to select the gear channel gear won't show up but Aux1 will.
 

Merv

Well-known member
#8
So if I understand, when you have assigned Aux1 to throttle, you can not select Rud>Aux1 mix. But you could select Rud>Gear.
AND when you assigned Gear to throttle, you can not select Rud>Gear mix. But you could select Rud>Aux1.
 
Last edited:

whackflyer

Well-known member
#9
So if I understand, when you have assigned Aux 1 to throttle, you can not select Rud>Aux1 mix. But you could select Rud>Gear.
AND when you assigned Gear to throttle, you can not select Rud>Gear mix. But you could select Rud>Aux1.
That's spot on.
 

Merv

Well-known member
#11
I was reading the manual, it said you can’t mix a channel that has been moved, it said to mix the channel first then move it.

So what happens if you mix Rud>Aux1 THEN assign it to throttle.
 

whackflyer

Well-known member
#13
Ok, I finally got it figured out. What I was doing wrong was when I went into the channel assign menu, I did not press the next button at the bottom of the screen, which did not take me to the menu i was supposed to be in. In stead, I was trying to assign throttle to channel six in the first menu. Thank you so much for the help, sir! The FT community is so great and helpful!!!
 

Keno

Well-known member
#15
I was having a similar problem on my DX6 updated to 2.00. I too was following the DX9 instructions, I am unfamiliar with its programing. To make my DX6 work, in Rx Port Assignments you need to assigned AUX1 to Aux1 then move to next screen and continue on. Only this selection allowed me to setup the configuration as per instructions.