• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DXe, Ar610, and Power Pack A help needed

#1
I'm hardly new to RC and flitetest as I've been a fan and scratch built for the past two years but I've run into an issue that's boggled my brain: my previous tx-rx combo has been compromised due to a neck strap failure but I have a DXe tx and ar610 rx. I've used the tx in the past for a BNF umx radian but I've never used the included receiver for my scratch builds. The problem is not in binding (the rx does give off a solid light after following the binding sequence) but somehow no power is going to the motor and I'm not hearing any of the sounds the emaxx 1806 used to make when I used my old tx-rx combo. After binding, I unplugged the bind plug from the rx and unplugged the battery from the esc (blheli 12a) then turned off the DXe. Next, I put the throttle stick to full throttle, turned on the DXe, then plugged in the battery so the esc would calibrate the throttle endpoints once I put the throttle stick back down to 0%. I'm a little lost because my motor is getting no power despite my 2-cell being charged up to 7.75 volts. Any advice for troubleshooting?
 

d8veh

Well-known member
#3
There are two versions of the DXe. The one with the two extra switches on the front (SPMR1000) can bind with any DSMX receiver, the one with the switch positions blanked off (SPM1000) can't.

Which one do you have?
 
#4
IMO it sounds like it seeing throttle input of some form. Is there any trim on that channel? Try lowing the trim to it's lowest down position. Do servos on other channels move?
 

Arcfyre

Well-known member
#5
Check to make sure the throttle cut switch is turned off. It's a long, two position switch on the top right hand rear side of the radio.

Switched back, or away from the gimbals is throttles armed. Switched up, or towards the gimbals is throttles disarmed.
 
#6
My DXe has the two extra switches on the front and the servos connected to the other channels work. I also tried lowering the throttle trim to its lowest and still no response from the motor. The long arming switch on the right hand of the tx is in the "armed" position. I'm still hearing no sounds from the motor that it used to make when I used my old tx-rx so perhaps the motor is done for?
 

Paracodespoder

Well-known member
#7
Turn on the tx before raising the throttle, then try again. Let us know if you figure it out so that others with the same problem can fix it. In my opinion the dxe isn’t very good for anything but bnf planes, they’re hard to program, and with mine the trim switches don’t work properly after programming, so it’s pretty much unusable. But before that it worked fine for any plane that didn’t need programming, now I have the dx6i, still can’t do differential thrust without a v-tail mixer, but it’s a lot better than the dxe.
 
#8
So something interesting happened; I turned on the tx and plugged in the battery (in the order that I usually would) and still no response, but then I turned off the tx while the battery was still plugged in to the rx and then the motor made the sounds it would when activated. Although, the tx was still turned off so it wouldn't receive any inputs, so I turned on the tx while the battery is still plugged in and now the whole system works perfectly fine. Kinda funny that it worked it out in that weird way but I guess this case can be considered closed!