• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Enabling flaps on Simple Storch

#1
I've finished my Storch scratch build, and have set up controls on my Spektrum DX6i transmitter and old 6 ch .Spektrum receiver. All the surfaces work and are centered. I went for the flaps option with two servos ( facing same way) on a Y lead.

I have read countless contradicting tutorials on setting up flaps through the GEAR channel using the DX6I GEAR switch , but no luck. No movement at all after enabling gear switch in a mix,setting U and D to positive and negative amounts.Also tried reversing . Nothing works!
I have also tried the same using the FLAPS switch with no results; and note that the monitor view shows movement on the AUX channel that aren't visible on the Storch.

The only issue I have noticed is that when i first connect to the Rx, the rudder oscillates violently before it settles down, then is fine. The other issue is that one flap servo buzzes all the time. It's a brand new servo.

Can anyone with my Spektrum setup help ? ?
 

Brett_N

Active member
#2
Go to system settings -> channel assign -> gear and make sure it's on the switch you want the flaps to be on.

Back at main aircraft page on radio, go to flaps, and select whatever that same switch is. Usually you want your flaps about 1 or 2s delay.
 
#3
Problem solved.
It was a simple oversight that the linkage rods were tightened down in the extended position, but with the flaps level with the wing; in other words the flaps were level with all the travel in the servo used.
Once re-centered, I now have working flaps on the gear switch.