• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Flaperon issues, with DX6 and Admiral RX600SP (mini mustang)

#1
Has any one had an issue with flaperons, where the stick moves the ailerons like flaps, and the flap switch moves them like ailerons? I have a DX6 with Admiral 6 channel with stabilizer plus. I have this setup on the simple cub and spitfire with no issues (used a spectrum ar620 on them).

I have tried swapping the ailerons on the receiver, setting the receiver as normal wing and flaperon, setting the dx6 as normal wing and as flaperon.

Wanted to try a gyro on the cheap, and found the RX600SP for $30
20200606_104445.jpg


...not sure which way is up, or if left is right...
 

Merv

Well-known member
#2
Try reversing the flap channel and/or aileron channel in the Tx. May also need to swap servo plugs in the Rx. Between reverse channels & swapping plugs, there are may combinations, one will work.

Be careful using flaperons, they can cause a bad tip stall when used on ailerons that are not full length.
 
Last edited:

Ryan O.

Well-known member
#3
Has any one had an issue with flaperons, where the stick moves the ailerons like flaps, and the flap switch moves them like ailerons? I have a DX6 with Admiral 6 channel with stabilizer plus. I have this setup on the simple cub and spitfire with no issues (used a spectrum ar620 on them).

I have tried swapping the ailerons on the receiver, setting the receiver as normal wing and flaperon, setting the dx6 as normal wing and as flaperon.

Wanted to try a gyro on the cheap, and found the RX600SP for $30 View attachment 171195

...not sure which way is up, or if left is right...
You may need to do what Merv said. You may also have to go to channel assign and change it.
 

Merv

Well-known member
#5
I reread the post & missed the stabilizer.
If the stabilizer is doing the flaperon mixing, then reverse the channels on the stabilizer not the Tx