• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Flysky th9x not working with Smart Propo Plus

#1
So recently I was digging though my old boxes and I found my old flysky receiver, so I decided that why not try to set up a simulator! After hours of downloading software after software, I got it to connect and work with other simulators(SmartPropoPlus), but there was one problem, the stick that controlled the elevators and ailerons wasn't receiving a an up or down input. I have spent a few hours researching and I was still unable to fine any info, so any info that any of you have would be appreciated:D
 

ofiesens2

Professional noob
#2
I've tried SPP a few times over the past year with my DX7s, and I can't it to function well. On the rare chance that the computer actually sees that I've plugged in the transmitter, all the inputs jump erratically up and down (randomly) as soon as I move any of the sticks. So its basically unusable for me. And yes I have played around with the settings.
I did some troubleshooting by trying it with different 3.5mm audio cables and also a different transmitter (DX4e) and I've concluded that either the software itself is somewhat faulty, or my computer is going nuts.
Let me know if you get this thing to work. A couple years ago I had it working well and taught my sister and father how to fly (somewhat) on the simulator, and it was a lot of fun being able to walk downstairs and fly before breakfast without charging a battery.
 

ElectriSean

Eternal Student
Mentor
#3
I have it working with my DX9, but I couldn't tell you how I made it work... I'm pretty sure there's some kind of voodoo involved, cause one day it didn't work, then one day it did. It's worked fine since as well, with both FPV FreeRider and Velocidrone. I just hope I never have to reinstall windoze.