Fried ESC


Junior Member

FT has gotten me into RC and I've started a build of the FT old speedster. During the setup, I was able to test the motor and servos fine.

After I had completed the build and went to test, the ESC burned up. Wondering what went wrong.

Here's the part list:
- Suppo 18A brushless ESC
- 2 Hextronic 9 gram servos
- Spektrum AR610 receiver
- Turnigy 1300 mah, 3S

Here's how the receiver was setup:
- ESC into throttle
- Rudder into Aileron
- Elevator into Elevator

Also, I ended up having to pull the receiver out of the power pod in order to connect the servos. Not sure how someone gets them wired up in the power pod.

Any advice would be appreciated as I'd like to understand what was wrong with the set up.



creator of virtual planes
What motor did you have on it and did the ESC burn out from running the motor, or did you never turn the motor on? Usually ESCs burn out when you try to draw too many amps threw them by using too big of a motor for the ESC. But it's possible that the ESC was defective.


Staff member
Wrong cabling might be a reason too. If you reverse polarity to the ESCs or the motor wires touch, the ESC gives you a smoke signal to tell you that this is not how it's supposed to be.


Professional noob
As for your problem about wiring into the receiver, I think most people (myself included) just Velcro it in there, so it is easily removable and re-attach-able.


creator of virtual planes
It could also be a bad connection. I was having ESC problems and I'm pretty sure I did a horrible job at soldering. It worked great for a while, but then stopped working. If I remember correctly, an ESC will not do any beeps if only two of the three connectors are plugged in. So if one connection isn't good enough... it won't work.


Junior Member
SOLVED! I reversed the outer two connectors on the ESC to rx connector. Now I get the beeps (odd sounding beeps on that Suppo!), and can program it. I really thought it was correct before, since the rx was binding correctly to the tx (according to the tx and according to the LED on the rx). Now I'm wondering how it can still be binding with the outer two connectors reversed! Those must be NEG and signal, so how can it bind both ways??! I also found out that what many have said about "you wont hurt the servo by connecting it wrong" is wrong. I got a whiff of smoke when subsequently testing a servo and immediately disconnected the servo but I assume it is toast. Again, I don't know what the pinout on the Suppo is, so have to guess.

For the record, and since there is no documentation I can find on pinout for the Orangerx 415x, the center pin of the "thro" connector is POS, the pin closest to the bind plug is signal, and the pin furthest away from the bind plug is NEG. Also the connectors are a smidge smaller than the usual micro servo connectors. I had to use an exacto blade to "trim" them down to fit. They are Micro Molex according to some folks... or Molex Blade... Not sure...


Church Meal Expert
They always put the positive pin in the middle so that even if you plug it in backwards, you only have your signal and ground reversed. You mention the TX didn't reach the servo wires and you had to move it.
You need some servo extension leads. Look on Amazon or Ebay, they are cheap.

Binding just means that the Rx and Tx are talking and recognize each other.
Do not infer anything else from a successful bind

Best regards,
Last edited: