• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FT Flyer motor (Turnigy Park300) suddenly shuts down and stops working!?

#1
Hello everyone,
I built an FT Flyer, and I really like it, but sometimes the motor suddenly shuts down....
When this happens, I can get the motor working again by fully going back on the throttle and then giving it some throttle again. When it happens, there is this weird sound: PHIEW....
I crashed a few times because of this, and I just broke a prop as well. I now only have 2 props left.

I have to say that I connected the wires using some Male-Female connectors and tape. I didn't solder them. However, I don't think the problem is with the wires, for I can't imagine that they will disconnect or something. I did try to run the motor and then pull one of the wires out. There was some weird sound, but it was different.

Does anybody have any clue of what's happening with my FT Flyer?? I want to fly it again :(
Is it the ESC? Or the motor itself?

Components I'm using:

Turnigy 1380 kv park300 brushless outrunner (recommended)
Turnigy Plush 18 amp ESC (recommended)
Turnigy 500mah 3S batteries (recommended)
8x4 prop (recommended0
Spektrum AR400 receiver
Spektrum DX6i Transmitter

By the way, the control surfaces ALWAYS keep working when the motor dies, so the problem is probably not with the radio system.
 
#2
Oh and, I did reverse the shaft of the motor, however, I did it exactly the way it should be done and it didnt seem to cause any issues.
 

jamboree1

Active member
#3
Those type of connectors you used cause a lot of resistance which could damage your esc if it hasnt already, which i suspect is your problem, the esc is failing
 

jayz 84

Posted a thousand or more times
#4
You need to solder the wires! Any slight failure in positive connection will cause a failure such as that. Ive seen it a few times and experience it myself on a test run. Everything works fine till you give if full throttle then it cuts out.. Try soldering the wires first. Then if that dosent work then youll need to look into your esc
 

devindied

SEL MEL CFI CFII MEI
#5
Go solder your wires. However, check your battery voltage as well. Check your ESC cutoff and see what its set at. Most ESC(if not all) have a cutoff on them when the battery gets too low to save your LiPos. Usually, as you described it, when it cuts off, you can power down to idle, then back up to get it working for a bit to bring it in for a landing. I suspect this is the real problem as you could still control the plane, IE, you had power. Most spektrum equipment faced with a brief power drop(shotty wireing or heavy amps pulled) will "brown out"

Hope this helps you.