• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Graupner 250Q RTF FPV Troubleshooting help

#1
I recently purchased the Graupner 250Q Alpha RTF FPV combo pack from the store along with Fat Shark Attitude V4 goggles. The manual says the copter should be already set to broadcast FPV with the included Helistar FT591 set to group D and ch4. I replaced the included dipole antenna with an Immersion RC Omni R antenna to match the one on the goggles but the screens show no picture after scanning and locking on ch 4. Fat Shark troubleshooting says this should most likely be an issue with the camera or transmitter.

Any experiences with this transmitter and camera that came with the quad? Suggestions for possibly replacing the transmitter and camera?
 
Last edited:

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#2
I'd check to make sure that the antenna is the correct one for the antenna port on the VTx.

There's SMA and RPSMA.

SMA-Chart.jpg

Is it consistently locking on the same channel or did you only scan once?
 
#3
transmitter connector is listed as SMA on specifications. Receiver on goggle consistently shows ch4 as being strongest signal and locks on to it. I've manually changed channels and gotten no video.
 
#4
#5
Yes, goggles lock onto channel and screens are lit black. That camera looks comparable to the Runcam Swift in the FT store. Was thinking of getting that since it has the 3 pin connector that the camera the quad came with has. Thanks for the help. I picked up the RTF combo since I'm just getting into the hobby.
 
#6
Yes, goggles lock onto channel and screens are lit black. That camera looks comparable to the Runcam Swift in the FT store. Was thinking of getting that since it has the 3 pin connector that the camera the quad came with has. Thanks for the help. I picked up the RTF combo since I'm just getting into the hobby.
Sounds like the camera then. The Swift is a good camera too.