• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Gremlin/Frsky R-XSR/QX7 Request for Information

#1
I'm having an issue with my Gremlin. I can't tell if it's the FC or the Receiver. Would someone who has a working Gremlin with a FRSKY R-XSR/QX7 combination please post their CLI dump from Beta Flight? I’ve got a couple of more things to try but I need a microSD card to flash the receiver first. Meanwhile I'd like to see what a successful set-up looks like and go line-by-line through it.

I’d really appreciate it! If I can’t figure it out I’ll post something more detailed in a couple of days.

Thanks in advance

k
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
Closest I can do is a Gremlin with an XM+ using a Taranis X9d. Lemme know if you do not get the specifics you ask for.
 
#3
Bottom Line Up Front, I think it will work.

The input from the XM+ to the FEMTO F3 is the same: GND/+5v/SBUS. So, as far as the F3 is concerned it should be essentially the same connections. As I understand the diff between the QX7 and X9D it's buttons, dispay, menus and capacity. Correct me if I'm wrong but I think you can share models between the two radios, but I haven't even gotten to that part yet :( I can't get the darn F3 to recognize the receiver and get an input from it. Most configurations in BF end up with a steady blue and flashing red light on the FC, except for one which I'm pretty sure shouldn't work as it's a SPEKTRUM1024! That's why I want to see what a good BF config looks like before I do anything else. Even tried turning inversion off via CLI, no joy.

 F3_Config.jpg

Attached is a picture of the FC installation. Thanks for the help!

k
 

French

Construire Voler S'écraser Répéter
#4
It looks like it’s wired up correctly. In your Ports tab on Betaflight, your UART3 should be set for Serial RX (yellow). Then on the Configuration tab the receiver mode should be RX_Serial and the Provider should be set to SBUS.

You need to make sure the settings save properly at each step. If those three things are setup and the RX is bound to your X9D, everything should work.

Don’t mess with inversion.

 
#5
It looks easy, it should be easy. . .
Baseline setup no receiver no UART=No blinking red/solid blue
Config>Serial based. . ./SBUS NO UART (Save/Reboot)=Blinking red/solid blue
Config>Serial-based. . ./SPEKTRUM1024 NO UART(Save/Reboot)=No blinking red/solid blue
Ports>UART3-Serial RX (nothing else selected for telemetry etc, Save/Reboot) =Blinking Red/Solid Blue
(Config>Receiver Changes to PPM RX Input at this point.)
Config>Serial-based. . ./SPEKTRUM1024 (Save/Reboot)= Blinking red/solid blue. Receiver tab shows colored bars and a colored model preview.
Config>Serial-based. . ./SBUS (Save/Reboot)= Blinking red/solid blue. Receiver tab shows no colored bars and a blank model preview
I'm going to town in a little while. I'll try to find a microSD and get the receiver firmware flashed a little later on. Hopefully that straightens it out. I’m not clear on what the blinking red is really saying but I’m hoping that once communication with the receiver is established it will go away. Right now I don’t think that’s happening.
 

ElectriSean

Eternal Student
Mentor
#6
It looks easy, it should be easy. . .

Config>Serial-based. . ./SBUS (Save/Reboot)= Blinking red/solid blue. Receiver tab shows no colored bars and a blank model preview
This is the correct config, the lack of the colored bars probably indicates the configurator/firmware conflict that's driving everyone bonkers lately. Make sure the configurator software on your computer is up to date, then flash the latest stable version of the firmware and try setting it up again.
 

PsyBorg

Wake up! Time to fly!
Mentor
#7
This may help point you in a specific direction mate...

Why does my Flight Controller blink/beep lots of times when powering up ?

During Firmware Boot-up the Gyro is Calibrated and should give three Beeps/Blinks. This indicates the Firmware is ready. Upon Arming there is one Beep which is from Syncing Video to a BB log.

If gives repeated 2 Beeps this means NO Valid RX - This could be a bad wire to RX, or RX not binding to TX, or TX not yet sending data.

5 short blink/beeps followed by any number of long blinks/beeps indicates an error code. Number of long blinks indicates the following error:
1. FAILURE_DEVELOPER: External interrupt of sensor failed to initialize.
2. FAILURE_MISSING_ACC: Accelerometer/gyro sensor is missing
3. FAILURE_ACC_INIT: Accelerometer/gyro sensor failed to initialize
4. FAILURE_ACC_INCOMPATIBLE: The found accelerometer/gyro sensor is not compatible/not the expected one
5. FAILURE_INVALID_EEPROM_CONTENTS: EEPROM/FLASH configuration content is invalid
6. FAILURE_FLASH_WRITE_FAILED: Write of configuration to EEPROM/FLASH failed
7. FAILURE_GYRO_INIT_FAILED: Gyro initialization of SPI MPU6000 accelerometer/gyro failed

The most common one seem to be error 2 where the accelerometer/gyro sensor can't be found, this is caused by a bad sensor or bad connections to the sensor, could happen because of a bad crash. On most boards gyro and accelerometer is the same chip so acro flying isn't possible when the accelerometer isn't found, it's not just the accelerometer that's bad but the whole chip.

Error 3, 4 and 7 could also be caused by a bad accelerometer/gyro sensor. Error 5 and 6 indicates memory read/write problem of the MCU (main processor). In most cases a new flight controller board will be needed if the user isn't for example able to re-solder the sensor.

Above are Hard Faults the Processor detects upon boot-up and initialization. Additional reasons for flashing LED and/or beeping are:
No signal from RX. This could be simply the TX is off or the wrong Model/binding selected or a hard fault of the RX like no power or bad cable.
Accelerometer Not calibrated if the ACC is enabled (check the CLI). If acc is enabled then it must be cal'ed once and typically done in the config GUI.
Copter titled too far if the Acc is enabled.
 
#8
Well...poo.
Got the microSD card and finally got the directory structure right. I unzipped the SD file and dropped the whole thing in. That gives you an extra tier in the directory structure and when the QX7 looks for the version file it's not where it expects it to be. Downloaded the most current FCC version of the R-XSR firmware dropped it in fired everything up and: FW update error Error Opening file. . . . Erased it and started over. Same result. The good news is I didn't brick it. It is still bound and the TX gets RSSI info so it knows its there. I'm going to give this a rest for tonight I think.
Oh, and thanks Psyborg! Does that information apply generically or is it specific to the Gremlin FC?
[Edit] ElectriSean-I almost forgot, I did check the configurator and downloaded the most current stand-alone version. Used both and have flashed the firmware several times now. After this last go around with trying to flash the RX, I think I'm going to give it a rest. Later I'll try to flash a different receiver (8XR) that I have for a fixed wing foam build. If that is successful I'll have a baseline for what a successful receiver flash looks like. I'm leaning towards bad hardware at this point.
 
Last edited:
#9
I'm thinking my FC is faulty, given that the receiver is bound and reporting RSSI:

CLI

# status
System Uptime: 29 seconds
Voltage: 77 * 0.1V (2S battery - OK)
CPU Clock=72MHz, GYRO=MPU9250, ACC=MPU9250
SD card: None inserted
Stack size: 2048, Stack address: 0x10002000
I2C Errors: 2, config size: 2019, max available config: 4096
CPU:19%, cycle time: 128, GYRO rate: 7812, RX rate: 49, System rate: 9
Arming disable flags: RXLOSS CLI

# c

ALL apps have been refreshed, all firmware updated. When RX is powered, blue led indicates, RSSI indicates. FC Blue/flashing red, no betaflight indications. Rechecked soldering, all clean joints, nothing shorted. Motors power when activated. UART3, Serial RX/SBUS selected. I'm out of ideas except to order a new FC and start again. Any opinions on whether to get the same FC or upgrade? FRSKY has an AIO option: XSRF3PO Flight Controller Integrated with FrSky XSR Receiver. Maybe a little big, but. . .
 

PsyBorg

Wake up! Time to fly!
Mentor
#10
We can see the connections on the FC side are ok.. Are you positive the wires on the XM+ side are correct? Do you have a multimeter you can do a continuity check on the wires between the receiver and the FC?
 
#11
Yes I have metered end to end, from the board side of the RX to the board side of the pad on the FC, and also for shorts and grounds. Connections are sound. I've ordered a new FC, we'll see how it goes from there. Wish I had access to an O-Scope. . .
 
#12
Well, I got the new FC in and wired up to the RX. At first I was having the same problem and thought maybe I picked the wrong component to change after all. During the troubleshooting, I had spent some time swapping the pins around on the RX side of the connector and had left the signal wire in the S.Port position. De-pinned and reinstalled in SBUS/PPM out and. . .we have signal in Betaflight! And, yes, in my exhaustive troubleshooting, I had SBUS/PPM out going to the FEMTO FC too with no indications. I'll put that board away somewhere with an note and someday when I get an oscilloscope, play with it a little more.
LoL, the Gremlin has put on a little weight, though. I shoe-horned a HolyBro F4 in there. It just peeks out the sides a little bit. I'll probably end up putting new wire on the ESC's but when I'm done I'll post up a couple of pictures. Tomorrow, ESC's and trying to figure out how to make the TX work a Quad. :)
 
#14
HA! Most likely not, I watched your vids though and it seemed to fly okay, thats partly why i dont mind the extra tonnage. I figure there's plenty of capacity. I'll put it on the scale when I'm done.
 
#15
WooHoo!! Got Gremmy all put together and hovered over the dog's bed in the living room! I've learned a lot, reconnected with aviation and got to practice my 'tron troubleshooting! Exactly what I was looking for! OpenTX is challenging but starting to make sense. JC at Project Blue Falcon (may he rest in peace) had an excellent video on setting up arming switches. Not the fancy sticky logical switches, just arming. I'll figure out the other stuff another day, along with PIDs and rates ;)

Oh and 105g with a 2s, Psyborg. But keep in mind, non-FPV.
 

PsyBorg

Wake up! Time to fly!
Mentor
#16
That is great to hear.

The Open TX is really not hard at all to work with if or once you have the basics for radio set ups down and understand that radios like Taranis using open TX have several ways to do the same thing which is what makes it versatile and confusing at the same time. PDF manuals, various peoples videos on how they use their gear, asking questions here in the forums are all parts of the process in learning and finding out what works best for you.

Like anything else.. do you want to learn what you do or simply be the "Monkey who flips the switch" and use cookie cutter solutions for your needs and stay in the dark not growing in the hobby.
 
#17
Not sure if you ever got your answer but I think I may have stumbled across it. I was fighting the same issue for a couple days, which is how I came across this thread. The issue for me was the yellow Sbus wire. It does not actually connect to the Sbus on the receiver. I believe you are actually supposed to be using the connection with 5 wires. The green wire is actually your Sbus wire. I had been using the 3 wire connector included I think this is actually for connecting a slave receiver. Anyway rather than redoing my soldering I simply used an exacto knife to lift the clip that holds the yellow wire into the connector. And then moved it one spot down where the green wire would be located. I'm in buisness! While searching for the answer it seems as though this is a common mistake, and I never found this solution out there. I kinda just had to stumble on it while making some educated guesses. I hope this helps.