• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Torque rolling to crash on launch

Heli-Yeah!

Gremlin on the Wing
#1
Well, I finally got everything together on my Funbat. (been waiting for my HK order to show up)
But now I have a problem! I took it out to maiden it, and when launched it just rolls CCW into the ground :black_eyed:.
I have tried the vertical take-off, as well as throwing it very hard into the wind, at a low stick position, but as soon as I give any throttle she rolls, and crashes :black_eyed:.

I'm running a "Blue Wonder" 1700kV motor, with a 8x4 GWS slowfly prop, on 3s lipo. I have also tried 6x5 GWS slowfly, with 2s pack.

What do you guys think the problem is?:confused:
 

SunShine

not crazy, just stupid
#2
have you checked your CG? and the angle of the prop? is it maybe too heavy? did you have enough speed? and finally: did you notice any difference between the props?
-A
 
#3
Your prop choices seem to be the wrong way around for the cell size.. usually you use a larger prop on a smaller cell count than with a higher count. That could be the source of your issue.
What throttle setting are you launching at? You need enough to get high to then correct the roll.
 

earthsciteach

Moderator
Moderator
#4
I was told that a smaller prop would result in less torque roll. I've been using an 8x4 prop on my wing. She does like to twist!
I bet the slow fly prop has a lot more bite resulting in more torque. Try an APC 6x5E.
 

ananas1301

Crazy flyer/crasher :D
#5
Yeah I also know it that you should use a smaller prop for less torque but to get the power needed out of it go one cell up with it.

So what you did was kinda the wrong way round.
Try 8x4 GWS on the 2S
and
6x5 GWS on the 3S
 

pgerts

Old age member
Mentor
#6
Well, I finally got everything together on my Funbat. (been waiting for my HK order to show up)
But now I have a problem! I took it out to maiden it, and when launched it just rolls CCW into the ground :black_eyed:.
I have tried the vertical take-off, as well as throwing it very hard into the wind, at a low stick position, but as soon as I give any throttle she rolls, and crashes :black_eyed:.

I'm running a "Blue Wonder" 1700kV motor, with a 8x4 GWS slowfly prop, on 3s lipo. I have also tried 6x5 GWS slowfly, with 2s pack.

What do you guys think the problem is?:confused:
As they say before:
6*5 or 7*4 on 3 cell
8*4 on 2 cell with 1700 KV "blue wonder"
The funbat should not roll but the response on the aileron is FAST! 3 turns per second is not bad. I have 80% expo on ailerons and it is still twitchy.

About half throttle and a gentle toss into the wind slightly up and the funbat should just go on if the rudders are not used.
That is with a battery of about 500-800 mAh. More battery to the 1700 Blue Wonder is to heavy if i should recommend.
 
#8
A few things to check:

-Motor angled slightly down and to the right (helps with torque roll)
-Battery and opposite side it's rolling to
-Maybe just needs a little trim.. Someone mentioned that roll response is fast so I assume a little trim can do a lot for you.


The blue wonder with 8X3.8 shouldn't be causing any problems on a 3s.. It was designed to work with that setup perfectly. A smaller prop with a 3s or 2s will only cause you to lose thrust.