• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

HKPilot Mega Mini

Vk2jma

Junior Member
#1
G'Day,
Has anyone worked out the correct OSD / Telemetry port connections for the HKPilot Mega Mini APM 2.5 knock off? It's the one port with no info to be found on the board or in the doc's?
Regards,
Mark
 

vk2dxn

Senior Member
#2
Hey Mark
I am interested in the mini so I'm subscribing to your thread.
Sorry I can not answer your question as I only have the 2.5 knock off.
My osd info is taken from the mav port that is a different plug to the rest on the 2.5

Later today I will compare pictures of the 2.5 and mini and try to give you an educated guess where to look.

Cheers

Paul
 

Vk2jma

Junior Member
#3
Some progress

G'Day Paul,
I've made some progress. The supplied Y lead has the wrong plug on the HKPilot end. Once this is swaped and the Tx and RX of the Osd are connected to the TX and RX pins of the HKPilot (that is tx to tx and RX to RX) the Osd came to life. To be fair the HK instructions do include this info, but in a comment about the GPS port! Still no joy with the data radios. The elevon mix setup for a wing has me stumped as well at the moment. I'll keep you posted, but I'd love to hear if anyone else has a working setup.
Regards
Mark
 

vk2dxn

Senior Member
#4
That's good you sorted that out. I ran out of time to take a look yesty.
As for the elevon mixing I am keen to find out about this as my fixed wing project is a delta and I was looking at the HK mini for this.
Look forward to next update
 

Vk2jma

Junior Member
#5
I managed to steal a hour today and got the elevon mixing sorted. The trick was to set up the flight modes first and get going in manual mode. Part of my confusion was I've re-flashed a mode 1 9x TX with er9x firmware and swapped the gimbles to make it mode 2. My rudder and elevators are still reversed however. Once is working in manual swap to fly by wire and get the software reversing to match manual mode under the radio setup screen.
No joy with the data radios however, still getting a no heart beat error even with the radios looking like they are doing there thing. The radios work with the FY31 so It's still most likely a user issue...
 

vk2dxn

Senior Member
#7
Have you got the data radios flashed to latest firm?.
I'm running the 915's from hobbyking and they work great but the standard antennas are rubbish
 

vk2dxn

Senior Member
#8
Just a thought

Are you selecting the correct baud rate in MP?
I am at work ATM so I don't have access to check it but from memory you need to select something like 5200 baud rate when linking via mav radios
 

Vk2jma

Junior Member
#9
9/10s

Thanks Paul.
Flashing the radio from within mission planner worked, although the ground is now v1.9 and the air v1.6. I'll have a read during the week, I do recall reading something about flashing the air end b4 the box arrived. The data radios and the OSD now work independently, but still not together. With the data radio and the OSD connected the OSD works and the radio stops. I might also dig out the CRO and have a proper look at what's going on. Fingers crossed the x5 may be back in the air next weekend.
Jma.