• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Hobbyking Blue Series 20A ESC and Simonk Firmware

voipmonkey

Senior Member
#1
Hi Everyone. Need Help ..
I have just taken my 20amp Blue Series ESC and tried to flash it with simon K firmware using LazyZero tool.
Everything seemed to go ok avrdude worked fine. BUT...
i connected everything up and all i now get is 3 beeps and the esc does not work.
what have i done wrong... i can re program the atmel chip no worries but nothing seems to work.
Stuck need help guys please.
Mark
 

PaulT

New member
Mentor
#4
Even after the flash, you still need to calibrate the throttle...every thing else (esc's setting) is in the new firmware.
voipmonkey - What tool did you use to attach to your esc's?
I need to make one and have seen various types...
 

voipmonkey

Senior Member
#5
Even after the flash, you still need to calibrate the throttle...every thing else (esc's setting) is in the new firmware.
voipmonkey - What tool did you use to attach to your esc's?
I need to make one and have seen various types...
Hi Paul
yeah leason learned here me thinks... i have a few to do for various crefts so shelled out the cash and got the Hobbyking avr 8 programmer. it is wicked place on chip the correct way of course :confused: and flashes great. i have done three now and all working good. now just got to get them ontothe talon tri i am building :)
Mark
 

Cyberdactyl

Misfit Multirotor Monkey
#6
Even after the flash, you still need to calibrate the throttle...every thing else (esc's setting) is in the new firmware.
I flew a V3.0 for maybe 3 flight hours without calibrating the throttle. Maybe I was just close enough for it to work well. But you're right, when I put in the KK2, I did go through the standard setup for that which included throttle setting.
 

voipmonkey

Senior Member
#7
Well these are working fine now. Just installed them into my Talon tri and will get it out when my new transmitter turns up. DAMN DX8 failed and got to send it back for repair :( not impressed.