• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Kiss fc issue with booting

#1
I recently built an alien and everything works but i have an issue when i plug my battery in sometimes it does not flash the blue light and nothing happens and wont connect to the gui but if i hold the button on the controller will connect to the computer and then i can plug my battery in have no problem flying a few batteries then i have to rinse and repeat... Any ideas on what to do to fix it?


I followed the build log from riot rotors video expect i used mr steele motors but that shouldnt have any effect with the kiss fc.. right?

Any help would be great. :) Thank you for your time
 

PsyBorg

Fly Angry
Mentor
#2
After you enter the gui with the bootloader do you save and automatically activate the FC? There is a software feature in it that will read the serial number and activate the FC if it is a valid number. If you don't save and activate it may have fraud prevention system in place that makes it not arm properly.
 
#3
I believe its activated

After you enter the gui with the bootloader do you save and automatically activate the FC? There is a software feature in it that will read the serial number and activate the FC if it is a valid number. If you don't save and activate it may have fraud prevention system in place that makes it not arm properly.



Capture.JPG

I have saved before and saw it change to activated. I add a picture of the GUI with what its set to.
 

PsyBorg

Fly Angry
Mentor
#4
You said this was a full KISS only with Steels motors correct? if you updated the FC and the Kiss esc's then you should be running Dshot 600 not oneshot 42. I made that mistake when I first upgraded mine and it saved at one shot 42. When I tried to take off in level mode it would flip like crazy. AS soon as I set that to Dshot 600 all the strangeness and bad behavior went away. Try setting that to Dshot and saving again.

This is what happens in auto level if you run RC 28 and 1.03 on the esc's and do not have Dshot 600 selected.