• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Kiss FC Not Arming

#1
I just built my first quad and I got the Taranis bound to my x4r and I installed the firmware for the Kiss FC. However, I can't get it to arm. I followed Rotor Riots instruction perfectly and Kiss GUI is showing the command for Aux1 but wont arm. Any suggestions?
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
Did you center the channels with subtrim and then set end points at 1000 for low and 2000 for high?. If your end points are set higher then the min throttle then it wont arm.
 

PsyBorg

Wake up! Time to fly!
Mentor
#4
Does the gui show the switch you used for arming actually working when you look at the receiver tab? When I set my devo 7 up I had to extend the travel for the switch I used to arm it so it would go from 1000-1500-2000. It was only going from 1300ish to less then 1800 on default set up.
 

PsyBorg

Wake up! Time to fly!
Mentor
#6
Are you sure the switch that you chose is actually set in the taranis to be the aux channel you assigned in the gui? Im in new territory as I don't use a taranis just going by what I see in the videos. Maybe redo the step where you choose the switch or maybe to trouble shoot try using a different one?

I'm not saying you didn't do thing right just thinkin thru the setup process and where things can get confused.

Oh and check and make sure you don't have a throttler hold possibly set up too that is locking it out.
 
#7
Yeah, I tried a 3 position switch and a 2 position switch. The Kiss GUI shows that aux 1 is moving from 1000 to 2000 when I flick the switch but it doesn't recognize that it armed it.
 

PsyBorg

Wake up! Time to fly!
Mentor
#8
The only other thing I can think to check would be the protocol.. like Sbus or ppm ... Do the ESC's sing and have blinky lights when you first power it up?

Another after thought... did you save the changes in the gui? It is really picky about changing pages without saving.
 

PsyBorg

Wake up! Time to fly!
Mentor
#9
Light bulb just popped on... Assuming you went full KISS with FC and ESC's.

Did you flash the FC to use Dshot? When I flashed mine it loaded dshot firmware but left it set to oneshot 125 after a reboot. Make sure that Dshot600 is selected
 
#10
Yeah to both things. This really suck no body can help me and this is my first build so I have already been challenged a lot. I never soldered before doing this and I spent 3 days on it for it to not program correctly. Do you know if Kiss has a customer support?

(Edit) I don't have the option for dshot right now I have oneshot 42 slected instead of oneshot 125 and PWM.
 
Last edited:

PsyBorg

Wake up! Time to fly!
Mentor
#11
I do believe you can contact them directly on their website. Flyduino.net. I also think they have a thread up on RCgroups as well.

Have you been able to spin the motors using the motors tab? Make sure they all spin and we can most likely rule out a bad esc. I would say go back and triple check the wiring for the esc's if one or more does not spin. All else fails you can carefully de-solder then and see if the fc will arm without them connected.
 

PsyBorg

Wake up! Time to fly!
Mentor
#12
Ok just saw the edit from the previous post.. Look on the Gui and tell me what firmware you have loaded please. Then tell me how many wires you are using from your receiver? This may be a case of pwm and ppm swapped.

Wait.... You have a taranus and an x4r? you should be using sbus I thought.
 
Last edited:
#13
On the GUI I have V1.14. I have the Rotor Riot setup with 4 wires coming from the receiver to the FC. I have the red, yellow, and black ones coming from the Sbus pins and the white coming from the smart port for telemetry.

(Edit) All of the motors spin in the motor tab.
 
Last edited:

PsyBorg

Wake up! Time to fly!
Mentor
#19
Save it and see did that solve the problem.

Save it. Disconnect. unplug the USB and then replug it in and reboot to make sure the change took effect