• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Kiss settings

#1
I have a kiss board and an x4r receiver. I have got the firmware on the board and am setting it up to fly. There is a drop down box in KissFC that has a list of recievers. Whitch one would my X4r be? I am not getting any other data outputs but my throddle and I think that box has something to do whith it. Please help.
 

PsyBorg

Fly Angry
Mentor
#3
Here is my RR5 Alien config full Kiss with x4r running sbus. be sure to drop that FS level to 0 as a race quad could be a 100 yards of more away in that time frame it defaults at. And set failsafe in the Taranis to no signal

Alien config small.jpg
 
#4
Thank you. I have set everything up the way your image suggested. I also set up the arm switch. I clicked save. Unfortunately, I still have no outputs. When I switched to the correct reciever in the drop down menue I lost the only output I had which was throddle. I am useing sbus. The way I can tell this is by looking at the output screan on KissFC. I do not even have outputs for my aux channels. Could this be a hardwire issue or something in my turranus or KissFC?
 

PsyBorg

Fly Angry
Mentor
#5
Look on the receiver tab and see what channel mapping is there. I use TAER and have my Taranis set to default at that mapping. It does not really matter just as long as the radio and the FC match.
 

PsyBorg

Fly Angry
Mentor
#8
Sorry mate didnt mean ta leave ya hangin. I had to step out and go pay rent so I can stay here typing at you guys.

The receiver tab will have a pull down menu to set the mapping and teh Taranis will have a default setting when you go into the system menu not the model menu. (long press enter) will be near the bottom of the list. If they all match then I would start all over with a totally new model (not a copy) and rebind the receiver to the new model. Then we can go from there if you still have issues.
 
#9
I hope I did not make you feel rushed. I found the channel mapping in my terrains but I still cannot find the pull-down menu or the receiver tap in KissFC. If you could post anouther screanshot that would help me alot. Thank you.
 

PsyBorg

Fly Angry
Mentor
#10
gah I work in too many different guis.. I guess when KISS sets the maps it reads thru SBUS what the radio mappings are. It is only PPM connections that dictate channel orders. Your receiver may be a non inverted signal type though so try non inverted. If that does not work try PPM using Throttle, Roll, Pitch, Yaw and see what that gets since the Taranis is set to TAER.

receiver.jpg

Its something really simple and I may be just over looking it.

No rush at all mate. I leave the forums up pretty much all day and peek in occasionally between doing other things. Like right now I am out to burn a few packs on this beautiful day while I can. Be back in an hour or so.
 
Last edited:
#11
I have been working on this Quad for a while. I have tried all the different Reciever options in my KissFC. I have also made a new model in my radio and successfully bound it. Unfortunitly i still have no data outputs. The only output I have is my troddle witch only works when I have the 4-6 channel reciever selected in my reciever tab. Do you think that i could have the wrong esc's for this particulare board? I am not useing kiss esc's. I am useing 2212motors whith the esc that come whith it. Do I need to flash firmwhere on the Esc eventho they are not kiss? Any ansers will make my day a hole lot better. Thanks for all the help.
 

PsyBorg

Fly Angry
Mentor
#12
What esc's? 2212 sounds more like an airplane motor and if that is the case and they came matched with esc's then they more then likely are not flashed for quad use mate.

I am not sure if it would be a matter of flashing the esc's to use blheli or if there is a difference between the physical make up of them. I will take a guess and say they can be reflashed but let us know what they are so we can investigate and be sure.
 
#13
I actually plugged in the sbus in the wrong slot on the receiver. I must have gotten the diagram mixed up. I cannot believe I missed it. It's a newb thing I guess. These motors and esc do look like airplane morors but it dose say they are for quads. They are Jrelecs 4x A2212 1000KV Outrunner Motor + 4x HP 30A ESC. I am haveing trouble calabrateing them tho. If you know anything about that please help. I would not be surprised if they need some kind of flashing but I have no idea.
 

PsyBorg

Fly Angry
Mentor
#15
I never worked with SimonK but I have read things that they don't play well in quad configurations on some firmware they have. Someone else more in the know would have to advise you on that. But glad you got the ports figured out. We all have been there. "I swear I set it all up and checked it three time" Done that myself. Some times a day away from a project and fresh look with fresh eyes does wonders.

Kinda why it takes me weeks to set up a quad properly to make it do what I want. I don't rush as things get over looked that should be obvious
 
#16
I am going to just get the kiss ESC's . If you think that's a bad idea lmk. I have read a lot on how those ESC's with the kiss is a good setup. I did get the calibrated off of my plane reciever but the board would not talk to them. Now I have some plane motors.