• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

KK 2.0 update for tricopter

#1
Hello fellow flyers. I am going to build the Bat Bone and I am wondering if the KK 2.0 update is really necessary. What is the update patching? The reason I ask this is because the usb programer on HK has been out of stock for a really long time. Thanks
 

Cyberdactyl

Misfit Multirotor Monkey
#2
The standout for the KK2 update from the shipped v1.2 is the auto level functionality. It is worlds better with v1.5. The additional gimbal support is nice, but probably rarely used by the user.
 

Johan

Senior Member
#3
+1,

auto level on the pre 1.5 versions is reportedly unstable. So if you plan to use it (auto level), upgrade to 1.6 or at least 1.5 otherwise you might risk strange flipping behavior (causing you to flip as well, maybe :))
 

kah00na

Senior Member
#4
+1 more, you will appreciate the update. The people in these forums that I've seen still using 1.2 always seem to have problems with theirs flying. Maybe you can find one on ebay.
 

DDSFlyer

Senior Member
#5
Finding one on eBay isn't that hard, not even expensive a risk if you get a dud. I was lucky enough to get one on my first try
 
#6
Hello fellow flyers. I am going to build the Bat Bone and I am wondering if the KK 2.0 update is really necessary. What is the update patching? The reason I ask this is because the usb programer on HK has been out of stock for a really long time. Thanks
I ordered one last Friday from eBay, received it Tuesday.. programmer worked great, first try

http://pages.ebay.com/link/?nav=item.view&id=321212184421
 
Last edited:
#7
Thanks guys I might buy from ebay but I'm waiting on motors on HK anyways so if those come in stock while the programmer isn't then I'll order from ebay.