• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lost Model Alarm

#1
Hey Gang

Well here is my first post. I recently purchased a Lost Model Alarm (LMA) from Hobby King (see below).

Signal Loss Alarm & Lost Plane Finder

The LMA came with instructions but they are not the best. I have got as far as to connect the unit between ESC and RX. I follow the usual protocol of turning on the TX and then the RX. When I power the RX the LMA makes two distinct beeps. After this I simply can't work out what the instructions are trying to say.

Any help would be greatly appreciated.

Kind Regards

DM
 

Trumpy

Junior Member
#2
Hiya DM , The two beeps are to let you know the system is armed and on . Hopefully you never need to use it tho, but if you do , you simply turn off your TX and the alarm will sound as soon as it detects there is no PWM signal being received , simple as that !

So hypothetically , you lose your model in some long grass or similar , you just turn off Your Tx and follow the beeps to the model :cool:
 
#3
Hey DM, welcome to the fourm. I think by reading the description, the first two beeps is telling you the system is Armed. And if u loose your plane in tall grass, woods,etc. Just turn off your transmitter while your plane is still on and the LMA should put off the 85d alarm....I think lol
 
#5
Hiya DM , The two beeps are to let you know the system is armed and on . Hopefully you never need to use it tho, but if you do , you simply turn off your TX and the alarm will sound as soon as it detects there is no PWM signal being received , simple as that !

So hypothetically , you lose your model in some long grass or similar , you just turn off Your Tx and follow the beeps to the model :cool:
haha you beat me to the punch...the page didn't update till after I posted and I saw pretty much the same thing between our posts lol
 
#6
Hey Guys

Still no luck. When I switch the TX and then the RX I hear two distinct beeps. I then proceed to fly the aircraft only to hear the LMA beep.

Cheers

DM :(
 
#11
Hey Gang

There are two distinct alarms;

Signal Loss Alarm

&

Discovery Buzzer

I have the former. I believe I have found the issue. I had the Signal Loss Alarm connected between the RX and ESC. If you don't adjust your throttle during a flight then the alarm sounds. I have since changed it to the aerolons and this has fixed the issue.

Kind Regards

DM
 
#12
I have 2 lost model alarms from hobbyking, one is the stock hobbyking alarm and the other is a " screamy " and when I hook either of them up to a free channel on my Rx they both constantly sound off!

any help would be appreciated!