• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

mini f3 PROBLEM HELP

#1
Hello everyone,

I recently just got a f3 mini magnum for a two inch quad that I am building. the FC runs omnibus f3. I flashed all of the firmware and everything seemed fine until I tried to arm and fly my quad. As soon as I try to arm it it freaks out in the yaw direction, and even worse when I try to add throttle, it just completely freaks out and flips out of control. All of the motor and prop directions are correct, any ideas? I also tried lowering the P value and it kind of fixed the yaw problem kind of but it still just looks like a Tasmanian devil on the ground. I also checked the FC direction and that was OK. any ideas?????????
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
If it looks like this then the FC is not facing forward and you need to set the proper rotation in the gui so it knows where front is.

 
#3
Thank you! The FC wouldn't fit properly in the correct orientation so i change the direction in beta-flight, and everything seemed to be okay but it still didn't work.
 

PsyBorg

Wake up! Time to fly!
Mentor
#4
So are you up or still goin crazy?

If you changed the FC and not the gui but you had correct motor order and rotations then you need to recheck the motor order and rotations again after you change the FC rotation in the gui.

So make sure that the flight controller rotation was set the proper way as it sits either +90 degrees vs - 90 degrees. Then recheck and make sure motor 1 is where motor 1 should be according to the diagram in Betaflight motor 2 and so on.
 
#5
still going crazy. I rechecked the motor direction after It but I'm not sure how to check what is motor 1 and what is motor two. thanks again so much for helping me out youre a life savor!!
 

PsyBorg

Wake up! Time to fly!
Mentor
#6
Right in Betaflight there is a picture of a quad. It shows what is motor one thru motor four as well as what direction they should be turning
 
#7
okay so im thinking i just compare that to where you can test what motor is spinning to what motor should be spinning? and if its wrong what should I do? because what i think from what youre saying is the motors might be spinning in the right direction but motor 1 or whatever isnt spinning as motor 1
 

PsyBorg

Wake up! Time to fly!
Mentor
#8
exactly. If that is the case you either need to rewire the esc's to the proper place on the pdb or change the signal wires from the FC to the pdb
 

PsyBorg

Wake up! Time to fly!
Mentor
#10
Well you will either have to pull the pins out of the connector between the two and rearrange them or you will have to reallocate resources in the command line.