• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Motor,esc,or bat?

Spbait

Junior Member
#1
Hello gang, new to electric foamys, (suppo motor, 18 esc, 3c 500mah bat) works fine on the bench! ( same setup with 2c500mah bat) no throttle? Battery was charged and works control surfaces but no throttle? Boggles my mind! Try another 2c 500mah bat same thing, no throttle? But 3c 500mah bat works fine? What the heck am I doing wrong?
 

Bolvon72

Senior Member
Mentor
#2
First thing I would try, even though it's strange one battery will run it but another will not, is to reset your throttle limits. With the battery unplugged max your throttle, connect the battery. You will hear a short beep, then throttle down, you will hear two longer beeps spaced apart. See if that works for you. (remove prop for safety).

edit: I am assuming you have a suppo esc, the beeps might be different for various ESCs.
 
Last edited:

Spbait

Junior Member
#5
Reset throttle limit and now works fine! Thanks good thing there are sites like this to help out a newbys like me! One more thing I need to know! Are there different types of prop adapters for suppo motors cause I ordered props and the hub is to thick and won't allow me to use the cone shaped prop nut on the front... I ordered 8x4 slow fly props?
 

Bolvon72

Senior Member
Mentor
#6
I had the same problem with the GWS style SF props, I drilled them out and sanded the hub until I could get it screwed on, then I switched to EXI props, no problem with the thickness and no more broken and bent props after one bad landing, or a dozen. But if you really want a prop saver, any 3.17mm will fit the prop shaft fine (if you have the 2208/14, check the listing for any others.
 
Last edited: