• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Help! Motor Problem

#1
I just build a new FT Delta Plane and was working on the electronics. I had a problem (See https://forum.flitetest.com/index.php?threads/electronic-problem-with-esc.58987). I went to a hobby shop really far from my house. They told me that my esc's amperage was too low and I had blown it out with my battery. I bought a 35a flite test esc and installed it. I got three beeps from the motor and then nothing after that. I have tried plugging the esc into channels 1, 3, and 4 on my receiver. I can get the motor to turn really weirdly if I plug it into Chanel 1 and move the right stick all the way to the top and then all the way to the bottom. I get two extra tones from my motor and then if I push the right stick up it moves roughly and back and forth. I would go back to the hobby store but it is a long drive from my house. Please Help!
 

Ketchup

4s mini mustang
#2
what do you mean by “roughly back and forth”. Is the motor pulsating? Also, have you tried the same thing with the esc connected to the throttle channel?
 
#5
I don’t know what Channel is throttle. I have tried connecting it to the channels I said above. I can’t calibrated it because the only tone that the esc makes is the three initial beeps.
 

Bricks

Well-known member
#6
When plugging in your battery to calibrate the ESC do you have the throttle sick all the way up wait for the beeps to pause then move throttle stick all the way down.?

You are on the internet look up your receiver to see how the channels are set up, and are you sure the receiver is compatible with your transmitter?
 

FDS

Well-known member
#7
As people said in your other thread pictures of everything hooked up and wired as you are trying to get them working will help a lot.