• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Multirotor pilot new to FW, questions about ESC setup

fiveaces

Junior Member
#1
I've only dealt with ESCs in multirotors, where with the KK board menu and programming cards, they're pretty straightforward to get working. I have a Lazertoyz ESC and 2 no-name ones from a local shop that I'm trying to get working in my first power pod. I'll explain my problems below, but it's worth noting: I've swapped out all the other parts when testing, so I know all the parts are in perfect working condition --- the problem is me

My problem is that I can't seem to get them working by following the (sparse) instructions. Most of the time I connect the battery, it beeps (one long high, with 3 short). From here, my servos usually work, and my motor either doesn't work, or will spin slowly at full throttle and full trim. Now at this point, a complicated series of unplugging things and plugging them back in, switching the TX on and off, and playing with the controls will eventually result in everything working 100%. But there doesn't seem to be any rhyme or reason to it, and I have to do it EVERY time I connect the battery.

When I first connected one of the ESCs, it went right into Programming mode and managed to calibrate it. However, I haven't been able to get back into Prog Mode since.

Like I said, every part is working, and I'm working with 3 different escs. I don't know what I'm doing wrong. I'm using a Turnigy 9x, but have the same problems on an HK Orange
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#2
5aces,

To get into programming mode on ESCs on fixed wing, turn on the tx, move throttle to full, then plug in the ESC.

The ESC will boot, notice the throttle is set way too high, and instead of arming it will enter programming mode.

First step is usually endpoint calibration, so when it beeps the second time, just pull the throttle down and it will remember what your radio calls full and idle throttle. It should then beep the cell count and arm. After that, it should behave more predictably

Now if you don't pull the throttle down, after a second or so, it will move on to the next programming option. It will then typically cycle through the options until you select something to change, however they rarely repeat the endpoint calibration option - you'll have to cycle power to get that option again. If you want to set/clear any of the other options (like setting the battery type back to lipo), you'll need the ESC's manual to decode which series of beeps equates to which feature.

Good luck getting your ESCs set up - using the tx sticks is always a pain, but a necessary evil when it comes to setting your endpoints without a control board helping you.


BTW, Welcome to the forum!
 

fiveaces

Junior Member
#3
Thanks for the response.

My problem is that I can't even get into programming mode. The lead is plugged into the correct channel (I've tried every channel and configuration just in case), I connect my battery, even with full throttle, and get three beeps, then nothing. It's not even armed.

I've gotten into programming mode a couple of times, so I know what to listen for.

Its not faulty equiptment, I've swapped out every part and every esc and get the same result.

EDIT: Ive found I can get it armed by going into Quad mode on my 9x, connecting the battery, then switching back to my Flying Wing mode. I don't understand why it won't start up in Wing Mode (or my other tx at all) when the only setting that is different is Elevons
 
Last edited:
#4
If you are saying all three ESC are misbehaving then the chances they are all faulty are very slim unless of course by the very act of connecting them up has damaged them.
It almost sounds as if there is something incorrectly set on your Tx.

I do like to test an ESC and motor on the bench at low power using a servo tester and simple choc block screw connectors as this completely avoids the radio link. I then know if anything misbehaves in the plane it is either a poor connection or something to do with the radio link.

I use this set up as my motor tester.
MotorTest.JPG
It only takes a minute to connect up any motor and plug in a battery. At the same time I usually mark the leads for the correct motor rotation.

I hope this helps.