Naze32/D4RII/Taranis Q X7 Problem


New member
I'm having a problem and I'm sure it's something simple, but I can't put my finger on it. My buddy bought a used ZMR250 race quad from someone with a Naze32rev5 and we had it running fine with a V8FRII and my Taranis X9D. However all of this gear came in so I was trying to setup it up with his D4RII receiver and his new Taranis Q X7 (which is pretty awesome by the way). I also have a ZMR with a Naze32rev6 and D4RII and have them setup just about identical.
So here's what I know:
  • The RX is bound to the TX and works fine with other models (not multi rotors).
  • I'm hooking it up with CPPM so I have the signal pins of channels 3 & 4 jumped.
  • I have power going into the RX from the regulator on the frame's PCB, and not through the 5V out on the Naze. (more on this in a minute).
  • I have channel 1 from the FC going into the signal pin of channel 1 on the RX.
  • In Cleanflight, I have the Receiver set to RX-PPM.

So here's the problem:
When I have everything hooked up, I plug the battery in and the Green LED on the RX shows it is bound to the TX, however it doesn't give the usual tones indicating everything is working properly. Instead, the ESCs/motors just continue steadily beeping, which I believe means it's not getting a signal. It will not arm and does not respond to anything from the TX.
When I have the board connected to clean flight, and I plug a battery in, it connects and everything runs just fine.

More on powering the RX, thought I'm not sure this would have anything to do with it. I know the RX is usually powered through the two pins adjacent to the channel 1 pin on the FC, however those aren't outputting anything. So the RX is powered through the same regulated pads that the FC is powered from on the frame.

Any help/ideas? I've also tried binding to the same setup with my Taranis to make sure it wasn't a TX setting. I've plugged both FCs (Mine and his) into Cleanflight and compared settings, which are basically identical. I've tried two different RXs. I also tried going back regular PWM and having 1 wire per channel and still have the same result. So the main difference in the two setups are the one that isn't working is a Rev5 and mine is Rev6. HELP!


New member
Never mind! Figured it out. It was indeed the way they had the FC powered. Can't be powered through Vbat. It needs to be powered through one of the motor pins.