Naze32 frsky telemetry with D4R-II



I just got my FrSky Taranis 9XD Plus today and so far im very happy with it except for one thing:
I can't seem to get the telemetry working. I get a correct battery reading inside of cleanflight.
This is what I've done so far:
- I bind the D4R-II reciever in D8 mode to the Taranis (flashed with the newest OpenTX version).
- I flashed my (factory new) naze32 acro with the newest version of cleanflight.
- I connected RX (green wire) and ground (black) from the smartport of the reciever to the frsky telemetry port on the naze32. I tripelchecked the wire orientation and resoldered just in case there was a bad solder joint.
- I enabled VBAT and telemetry in the cleanflight configurator (both using CLI and in the configurator itself).
- in the taranis, I made a telemetry page where nearly every telemetry parameter is shown (accelerometre, cells, cell, batt, A1, A2 etc.).
- I get the tx battery voltage in the batt column and the reciever voltage (~5V from the polulu) in the A1 column.
- I armed the naze32 (I read that the naze only sends data to the telemetry pins when armed).
- I also get the RSSI reading on the taranis.
- I tried using the "set telemetry_inversion = 1" command in CLI.

Everything is acting like there was no connection between the D4R-II and the naze32. The telemetry itself is working (with RSSI and A1 showing on the Taranis).
I tried connecting a USB -> RS232 adaptor to the naze32 telemetry pins, but I did not get any data. Maybe the naze32 isn't even sending data to the reciever?

I read online that I should get kicked out of cleanflight when telemetry is enabled and I am connected to the naze via usb. However, I can happily change settings when the board is armed. That seems odd to me...

I would be really glad if someone of you could help me.
I'm a little bit angry at myself to start this thread even when theres so much information out there about frsky telemetry on the naze32, but I maybe watched about 4 hours of video footage of people just connecting the things together and it worked out of the box and read about 20 forum threads about the topic. Why doesn't it work for me like everybody else?

Sorry for the double post (this is posted again in Transmitters and Recievers) but I figured that this maybe was the proper sub-forum to post this in...

Thanks in advance


Hi C0d3M0nk3y,

I just tried that after a short break for my brain without reading your post (I didn't think anyone could answer that fast) and that got it working. I feel so nooby right now :D
Thanks so much, even if I found it out myself, it soo good to know that one can get help so fast online.

That's what I get for doing nothing all day than flashing my X8R recievers to non EU firmware, flashing my D4R-II to 27 ms, flashing the internal XJT of the Taranis to non EU, flashing the Bootloader of the Taranis to OpenTx (not frsky) and flashing the opentx firmware onto the taranis aswell.

Thanks so much again, I should probably go to sleep now. :D


Posted a thousand or more times
Thanks so much again, I should probably go to sleep now. :D

No problem. That option is new as of version 1.8 or so, so that's probably why it wasn't mentioned in some of the tutorials you were watching to set it up.