• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Need help with Rx problem

d8veh

Elite member
#1
I just built a Simple Scout. I'm using a Motive-RC R8SB Rx a Jumper T12 Tx running a version of Open Tx. I tested everything before assembling, then I tested again after I installed each servo. Everything worked perfectly apart from the first problem 1 below. Finally, everything is installed and ready to fly until I accidentally connected the battery before I switched on the transmitter, which made the servos go full range backwards and forwards, though not the motor. I switched on the Tx, but problem 1 might have prevented a quick bind, so I unplugged the battery to prevent the ESC from over-heating.

Now I have problem 2: When I connect the battery with the Tx switched on, it seems to bind very quickly, so I have about 5 seconds of control, then all servos go full-range backwards and forwards a couple of times, then settle on full- range. By full range, I mean starting on 90 deg to the servo, then going right round to about 20 deg past in-line with the servo. They stop there with the ESC over-heating.

Problem 1 happened throughout the build: I bound the Rx in the normal way, and it worked like expected. If I disconnect the power for a few minutes, then reconnect, it re-binds straight away; however, if I disconnect and leave it for half an hour or more, then reconnect, it won't rebind automatically. The only way to get it to rebind is to activate the bind on the Tx (bind flashing), then, after a few seconds, the Rx binds without pressing the bind button on the Rx. Automatic bind is ticked on my Tx. Is there something disabling it? Is that what happens if you don't have it ticked?

Anyone got any ideas what I can do to get it working properly.
 

d8veh

Elite member
#2
Quick update. I disassembled everything and rebound the receiver. Everything is normal until I plug in the ailerons, which are on a Y-lead. It's OK for a couple of seconds or so, then it goes nuts. That's after I plugged in and tested the elevator and rudder and left them plugged in.

I just had my first plane crash before I ever got the plane out of the building room. When everything went nuts, I tried to disconnect the battery, but in my panic, I knocked the transmitter on the floor, which gave full throttle and broke a switch. The power pod sitting next to the plane leapt into it, then off the bench, dragging the plane with it until everything was on the floor in a pile, by which time I'd picked up the transmitter and cut the throttle. The propeller made a big cut and dent in the front of the wing and there was some other minor damage.

The ESC is one of these cheapo quadcopter ones. Could it be that it can't provide enough power for 4 servos? It's supposed to give 2A. When it goes nuts, there's no servo input, so it's not like something is getting over-loaded.
https://www.ebay.co.uk/itm/A2212-10...h=item41e10f43b7:g:OesAAOSwnHda6YlW:rk:1:pf:0
 
Last edited:

Hai-Lee

Old and Bold RC PILOT
#4
I had a similar issue with a totally different radio setup and I eventually traced the fault to the BEC not being up to the task. In my case everything would initialise quite well. The plane would fly without issue but every now and then the plane would suddenly lose control and crash. After many rebuilds and deliberate flying there appeared to be just a couple of maneuvers that caused the lose of control.

Simulating the problem of the ground with a tethered aircraft soon showed the issue. My BEC was running at max capacity and after a time of flying which warmed up the ESC the BEC overheated and shut down the voltage to the Rx. This "brownout" caused a loss of signal and the servos would "hard over" and the result of course was a rapid ground impact.

Now I calculate the total current requirements of the electronics and spec my ESCs accordingly or fit an external UBEC.

Just my own similar experience!

have fun!
 

Merv

Legendary member
#5
then all servos go full-range backwards and forwards a couple of times,

if I disconnect and leave it for half an hour or more, .

I use Er9x not Open Tx. On Er9x there is a mode to do a range check, the Tx will continually move the servos. Go to the screen on the Tx that shows what the servos are doing. If the servos are moving, your in a similar mode.

"if I disconnect it" I'm assuming you are turn off the Rx but leave the Tx on? Is it possible the Tx knows is not connected and going to a default mode? You might try not using the Auto bind.

When you servos are "going full range" are they hitting anything? If so they are binding, trying to move but are being prevented. This draws a huge amount of power.
 

d8veh

Elite member
#6
Thanks guys. It's sorted now. When I ulled the receiver out of the lane and connected just the ailerons, then wiggled them by violent movements of the stick, I could see the green light flashing off occasionally. I replaced the ESC with included BEC with one of my Flitetest ones, and now it works perfectly. I can now go flying tomorrow, yippee!