• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Newbie Needs Help! - Can't Seem to Bind iFlight Cineebe 4K (Frsky mini xm+) BNF with my Jumper T16

#1
I'm very new and green to this FPV world. I come from the DJI world where (for 90% of the settings) everything is done for you and all you have to do is take the quad out of the box, update any firmware and go out and fly.

I'm just starting to get into this new FPV venture, and so far it has been quite the challenge and a steep learning cure. I don't mind a challenge and thrive on learning new technology, but when there is no base to start from, it can be very frustrating and disheartening! In any event, here is my situation and hope someone can steer me in the right direction:

After reading a number of forums and watching numerous YouTubes, I decided to purchase the iFlight Cineebe 4K (Frsky mini xm+) BNF and the Jumper T16. I decided to purchase the iFlight Cineebe 4K because of its 4K camera and it appeared to be easy to fly specifically when using 2S Lipos.

My issue over the last few days since both of my little toys arrived is to try and get them to talk and work with each other. I've spent hours and hours to get them to work with zero success. Being a newbie, I don't know if it's something I'm doing wrong or if it's a problem with the hardware!

Problem Encountered:
I set a model in my T16 to MULTY FrSky D16 and it seemed to bind. However, I can’t get the quad started. No matter how I move the sticks nothing happens.

I connected it to BetaFlight and on the Receiver tab, it clearly shows that my sticks are not active as if it is not bound. I have no problems starting the motors manually from the Motors tab on the BetaFlight application.

The interesting thing is that the first time I bounded the quad to the T16, BetaFlight showed that the my joy sticks were reversed in both directions (a sort of Mode 1 with the throttle on the right stick but setup as left to right as opposed to up and down). At this point I decided to re-bind the Cineebe again and from this point on joy sticks have no affect even in BetaFlight.

I tried to use the D8 option, but it doesn’t seem to bind with this protocol

I hope that someone can shed some light on what I'm doing wrong.
 

Attachments

#2
Looks good, need to give the craft a name though:) I think you are not binding, dont worry about anything else until you see them sticks moving in the receiver tab. On the ports page, is that the correct uart for the receiver? (different for different quads wiring). FIRST read up on the lights for your receiver, the lights will tell you if it is binding and if it is bound and receiving stick commands. Another important thing...some receivers wont work without battery power, power it with the battery and then plug into betaflight. Use d8 and rebind.
 
#4
Looks good, need to give the craft a name though:) I think you are not binding, dont worry about anything else until you see them sticks moving in the receiver tab. On the ports page, is that the correct uart for the receiver? (different for different quads wiring). FIRST read up on the lights for your receiver, the lights will tell you if it is binding and if it is bound and receiving stick commands. Another important thing...some receivers wont work without battery power, power it with the battery and then plug into betaflight. Use d8 and rebind.
Hi,
Thanks for your quick reply and much appreciated. I'll tried binding it again using the D8 and change the UART and see what happens.

Sorry for the dumb question, bu should the motors on the Cineebe not start right away before connecting it to BetaFlight to find out if the sticks are actually doing something?
 
#9

Attachments

#10
The radio will talk to the receiver but the receiver wont talk to the flight controller if the serial communication is on the wrong port. You wont see it in betaflight. Try uart 2, i think that will fix it. just click the serial rx switch on the ports page. turn 1 off and 2 on save, power cycle battery and usb unplugged. DO NOT MESS WITH THE USB PORT SWITCHES. Since the xm+ does telemetry, if your are bound and you try to turn the radio off it will say something like "receiver still connected"...i'm not sure with the t16 but my taranis yells at me.
 
#11
please...i'm not sayin this to be a jerk but if you wanna avoid serious i mean serious injury...take them props off. hundreds of pounds of thrust on each blade...it will str8 cut your finger off.
 
#12
awesome drone by the way
It will be if and when I can get it working!

Can you confirm my previous questions:

(1) Will the motors on the Cineebe not start right away before connecting it to BetaFlight to find out if the sticks are actually doing something?

(2) If the UART is not set properly, is this the reason why the sticks will not to talk to the receiver?

Thanks,
Sam
 
#13
The radio will talk to the receiver but the receiver wont talk to the flight controller if the serial communication is on the wrong port. You wont see it in betaflight. Try uart 2, i think that will fix it. just click the serial rx switch on the ports page. turn 1 off and 2 on save, power cycle battery and usb unplugged. DO NOT MESS WITH THE USB PORT SWITCHES. Since the xm+ does telemetry, if your are bound and you try to turn the radio off it will say something like "receiver still connected"...i'm not sure with the t16 but my taranis yells at me.
Hi,

Regarding your other comment "please...i'm not sayin this to be a jerk but if you wanna avoid serious...." I really appreciate the advice and I don't think you are trying to be mean at all.

I hope you are right in that the UART2 will fix my issue! That would be sweeeettttt!

Thanks so much and I'll let you know if this works. I'm at work now so I won't have a chance to try it until later this evening.

Cheers,
Sam
 
#14
It will be if and when I can get it working!

Can you confirm my previous questions:

(1) Will the motors on the Cineebe not start right away before connecting it to BetaFlight to find out if the sticks are actually doing something?

(2) If the UART is not set properly, is this the reason why the sticks will not to talk to the receiver?

Thanks,
Sam
1. still kind of confused by what you are saying here. If you are bound (by the green lights i think you are) and have to be bound in right mode (d16) (if you change this on radio have to rebind) then the best way to determine if everything is working is in the receiver tab of BF.
When you power the quad up the motors might beep and twitch but shouldn't move until you arm the quad and give throttle.

2. if the correct uart is not turned on (in betaflight) the radio can talk to the receiver, BUT the receiver cannot talk to the brain (flight controller). So yes you will not see stick movement in betaflight and it wont work.
 
#15
1. still kind of confused by what you are saying here. If you are bound (by the green lights i think you are) and have to be bound in right mode (d16) (if you change this on radio have to rebind) then the best way to determine if everything is working is in the receiver tab of BF.
When you power the quad up the motors might beep and twitch but shouldn't move until you arm the quad and give throttle.

2. if the correct uart is not turned on (in betaflight) the radio can talk to the receiver, BUT the receiver cannot talk to the brain (flight controller). So yes you will not see stick movement in betaflight and it wont work.
Sorry I wasn't clear in my question (1) and I think I confused both of us.

What I was trying to say is that I can't even arm the motors even if its (supposedly) bound as shown in my screen capture, and that is why I asked the second question.

I assume that (as you stated) because the receiver can't talk to the controller, due to the being set to the wrong UART, then this is why I can't power it up either? Is my assumption correct or am I still totally out to left field?
 

FDS

Well-known member
#16
First off, have you got the Betaflight Receiver tab working? That is priority one. If you don’t get movement on your screen layout in Betaflight then you won’t get anything else happen. The quad will not arm when connected to USB or when it doesn’t have a receiver connected that it can “see.” Also it may have a different switch selected for arming than the one you are trying.
Also CLI DUMP AND BACK UP EVERYTHING, plus save your profile somewhere on the computer. Watch this s video, it shows you how to do that. DO NOT CHANGE ANYTHING until you have saved the original set up.
You don’t want to re flash the FC board. Ignore that part, it’s about the 8:00 mark for saving your set up.
When you get that done skip to the part where he sets everything up, follow that.
 
#17
First off, have you got the Betaflight Receiver tab working? That is priority one. If you don’t get movement on your screen layout in Betaflight then you won’t get anything else happen. The quad will not arm when connected to USB or when it doesn’t have a receiver connected that it can “see.” Also it may have a different switch selected for arming than the one you are trying.
Also CLI DUMP AND BACK UP EVERYTHING, plus save your profile somewhere on the computer. Watch this s video, it shows you how to do that. DO NOT CHANGE ANYTHING until you have saved the original set up.
You don’t want to re flash the FC board. Ignore that part, it’s about the 8:00 mark for saving your set up.
When you get that done skip to the part where he sets everything up, follow that.
Thank you and MorningViewFPV for your valuable input and help.

Hopefully by setting the Serial Urx from UART1 to UART2 will resolve my problem.
I will let you both know hopefully by first thing tomorrow if this was all a "dream!"
 
#18
Thank you and MorningViewFPV for your valuable input and help.

Hopefully by setting the Serial Urx from UART1 to UART2 will resolve my problem.
I will let you both know hopefully by first thing tomorrow if this was all a "dream!"
Hi,
Changing to UART2 worked where the stick movements correspond to the those in the Receiver tab. I even set up the arming swich which seems to work because a quick repetitive blue light flashes when I switch it on, but I still can’t start the motets when I push the throttle up.

Here are my new inputs and outputs that I also had to change in order that the movements if the sticks correspond to those in the Receiver tab of the BetaFlight.

What else am I missing in order to start up the quad?

Sam
 

Attachments

FDS

Well-known member
#19
Your inputs don’t match the mixer at present. The channel order is different. It should be AETR on both from channels 1-4. 1- Aileron, 2- Elevator, 3- THROTTLE, 4- Rudder. Move the Throttle in inputs to the right place.
You should also set up your aux channels in there. Have a look at this video , the screens are slightly different but Jumper uses a slight change to OpenTX, the basic workflow is the same.
You should also set all your endpoints up so the bottom of the sticks is 1000 and the top is 2000. Calibrate the gimbals through the radio first.
If having everything above set up doesn’t get you armed then you need to change the minimum throttle value, use the CLI command
get min_check
Look at the value. If it’s lower than the bottom value of your throttle stick then it won’t arm. Read your min throttle value, then use
set min_check XXXX
The four XXXX would be swapped for your minimum throttle value plus 10.
 
#20
Your inputs don’t match the mixer at present. The channel order is different. It should be AETR on both from channels 1-4. 1- Aileron, 2- Elevator, 3- THROTTLE, 4- Rudder. Move the Throttle in inputs to the right place.
You should also set up your aux channels in there. Have a look at this video , the screens are slightly different but Jumper uses a slight change to OpenTX, the basic workflow is the same.
You should also set all your endpoints up so the bottom of the sticks is 1000 and the top is 2000. Calibrate the gimbals through the radio first.
If having everything above set up doesn’t get you armed then you need to change the minimum throttle value, use the CLI command
get min_check
Look at the value. If it’s lower than the bottom value of your throttle stick then it won’t arm. Read your min throttle value, then use
set min_check XXXX
The four XXXX would be swapped for your minimum throttle value plus 10.
Hi,
With regards to the channel order, the way you see them in the screen shot is the only way that I could get them to work such that if I moved the throttle on the radio the throttle indicator in the Receiver tab also moved. It was strange for me as well to see that especially someone like me who doesn't have a clue of how to set this all up.

I'll see about checking the sticks endpoints.

Thanks for your help (again).
Sam