• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No Radio Found

#1
Taranis X7 - No Radio Found. Went through all the answers and checked everything but without success. Using Open Tx Companion 2.2.2 - the firmware was flushed without a problem. The SD card shows as a drive (D:\) on the computer but not the radio. When plugging in the radio the USB port initiate, with or without the SD Card (Radio ON or OFF). Tried when started up in Bootloader 2.2.2 but still no joy. I have reinstalled Companion 2.2.2, changed cables, set up a new model and tried to upload but the same message is returned.

NoRadioFound.JPG Drives.JPG Devices.JPG MassStore.JPG Zadig.JPG
 
#3
The device driver for the Joystick (FrSky Taranis Joystick) is loaded but it does not connect to radio and has no effect on the simulator.

RadioProfile.JPG Joystick device.JPG JoystickSimulation.JPG

When using the bootloader the following message is displayed on the Taranis:

OTX Bootloader - 2.2.2

USB Connected
 

d8veh

Elite member
#4
I have the opposite problem with mine. It won't work as a Joystick. The answer I was given is that when you flash the firmware, you get a choice of normal USB or Joystick mode. Once you make a selection, you can't change it in the settings - apparently. That's why I asked if you had been using it as a joystick.
 
#5
Thank you d8veh for your help but I do not receive a choice when flashing the firmware. What I do receive, and I don't know what it means, is the last message after downloading the software: File downloaded successfully - Invalid DFU suffix signature - A valid DFU suffix will be required in future dfu-util release!!!.
 
#6
Only time I receive a choice is, after powering up the transmitter and connecting the USB is - USB Joystick (HID) or USB Storage (SD) . Selecting the first option loads the Joystick device driver but there it all ends. I have no problem with the SD card.
 

PsyBorg

Wake up! Time to fly!
#7
Last time I updated open tx there was a box that had to be checked somewhere telling it to use sd or usb.

Is that still burried in the companion menus or did they automate it?
 
#8
The -massstorage and -cli check boxes was removed from the radio settings.
cli: instead of joystick emulation, USB connection is Command Line Interface - STM32BOOTLOADER DRIVER ?
massstorage: Instead of joystick, USB connection is mass storage (as in the Bootloader) - USBSTOR DRIVER?
only after changing the FrSky Taranis Bootloader driver to the USBSTOR driver did the SD card show up as a drive (D:\)
Connection available to up and download firmware via dfu-util, but the Taranis X7 radio is not recognized as a device

RadioProfile.JPG RadioProfile2.2.0.JPG RadioSettings.JPG
 
#10
The problem seem to be the USB port. Both FrSky drivers run without a problem with the USB2 port (driver). As soon as it encounters the Intel USB3.0 port, it will initiate the driver, but it does not open the drive. The FrSky-mass-storage-driver was replaced with the Microsoft-mass storage-driver, thus it is possible to read the SdCard. I have asked for some help from the GitHub community but not sure if it the correct platform.