• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Noob stuck with KK2.0

#1
Hi, i have built a H-quad with 2200kv DYS motor, 40A esc DYS, 8x4 tri-blade propellers and 3300mah 11.1v battery.
KK2 board flashed with the 1.6 firmware. it is not taking off when i give throttle it is rolling towards right i have tried calibrating esc by throttle pass through method ,adjusting the gain values and adjusting the trims to zero in the receiver and also the motors are acting up one of the motors suddenly starts to spin at full speed and the response is slow. Is there anything im overlooking or is it the PID values ???? i use a FLYSKY RX/TX pair. Thanks in advance.
MC.
 

Cyberdactyl

Misfit Multirotor Monkey
#2
Since you didn't mention it I will, but with the detail you've included, I can't imagine you over looked this.

Do you have 2 CW and 2 CCW props mounted?
 

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#3
I always go with calibrating ESC's. Seems obvious, but I think it's something that hurt me a lot when I was starting out, because I was often in "too much of a rush"to do it.
 

Cyberdactyl

Misfit Multirotor Monkey
#4
I always go with calibrating ESC's. Seems obvious, but I think it's something that hurt me a lot when I was starting out, because I was often in "too much of a rush"to do it.
Me too. But I was somewhat forced to flash my ESCs with my USBasp tool.

The serendipitous event was my first order from HK I bought an ESC programming card. It was DOA. I ordered another and continued to build. It also arrived DOA. So I made the required cable and flashed the ESCs with the simonk hex. Now that I look back, getting 2 dead cards was a blessing in disguise. I may have never flashed them.
 

Thinc2

Junior Member
#6
What do you mean when you say it is not taking off, but that it is rolling right? sometimes when you first take off you need to use a little stick to keep it level until you get off the ground.

You have an unusual combination of motors etc - what is the total all up weight - you might like to check ecalc to make sure you have enough power to hover.

The issue of one motor suddenly starting to spin - sounds like an ESC. Make sure you have done a receiver check and ESC calibration is done. It's easy enough on the KK2.
 

Liemavick

Member
Mentor
#8
Double check you wire connections, all ground facing right direction. The flipping sounds like you need to reverse your "roll". As far as the wonky motor I agree you may need to recalibrate your ecs's. After you've made the adjustments recalibrate your stick centering and throttle. Be sure you have quad selected, and not Tricopter configuration. Just some thoughts, good luck.