Help! Octo Pi/OctoPrint on the RaspPi 2 board?


Elite member
Withe the recent stupidity of pricing for the Raspberry Pi 3 and 4 boards, I decide to try running OctoPriny on the Sasberry Pi 2 board. I see several youTube posts about doing this when the V2 board was the new hot poo.

I cannot get the wifi adapter to work. I have tried several different dongles, one that is specifically listed for use with Linux OSs. None of them seem to work.

Any Ideas? Is there an older version of OctoPrint OS available somewhere that I cant't seem to find?

The youTube videos never mention anything about having enable the dongle driver or updating the driver, they just show the samed edits to enable WAP log in. The imaged SD card works in my RasPi 4 boards with onboard wifi, just not in the V2 board with any dongle.

Thanks for any insights anyone might have.


Troll Spammer
Hmmm. I have always run wired network to my OctoPrint Pis and have run on pi3s and "other" (ASUS) micro Linux boxes. Will have to dig out a Pi2 to play if nobody else has has any ideas.


Troll Spammer
I found my Pi2 and wireless dongle. If memory serves me correctly, there was a limited number of dongles that used to work with Raspbian. The Tenda I have being one of them. I had quite a few others that just would not work. Something about the max current that the USB ports could supply, and/or the amount of power that the 5V power supply used can provide. I have Wireless (Tenda wifi dongle), OctoDash, octoprint 1.7.2, and a touchscreen currently running on the box with no issues.


pi@octopi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"


Troll Spammer
Looking at my WifiConfig......

Wifi config is in /boot/octopi-wpa-supplicant.txt

You should enable connection to your network in that file

## WPA/WPA2 secured

There is also a list of known working dongles at this address:
Last edited:


Elite member
I have that all set up correctly but the wifi still doesn't work. For now, I just ran a LAN connection. Not as convenient, but it works.


Troll Spammer
you could try powering the USB dongle off a powered USB hub.

  • A Wi-Fi adapter will probably need more power than the Raspberry Pi USB port can provide, especially if there is a large distance from the Wi-Fi adapter to the Wi-Fi Access Point, or it is transferring large amounts of data. Therefore, you may need to plug the Wi-Fi adapter into a powered USB hub.


Well-known member
Using this on a single board computer running Raspian... Works great.

Here is the board WITH the wifi.