Help! please help with tanaris hookup on windows 10


New member
I have tried everything to updating firmware via SD card.
I got it to show in device and printers as a storage device then changed usb to joystick and it was still saying unrecognized joystick.
I have since installed another HDD on my computer with Ubuntu on it and loaded Velocidrone on that it worked for the first day now it's crashing every time i load a game so i tried my ubuntu laptop and the same thing happens velocidrone crashes when trying to load a game.
I cannot win :(
Now my flight controllers wont hookup to betaflight ethier.. another issue probably solved on ubuntu yet to try that one. Joystick is my main issue i want more stick time :)
Its getting better weather now so i can get out with my quads but i don't wanna practice tricks IRL without simulator hours.

Thank you to anyone who can point me to a solution as you can tell ill bloody load anything onto another HDD just to get this solved!

Kind Regards


Elite member
You want to get it set up as a controller for sim?
Which Sim are you running?
The betaflight issue will be drivers, did you use the Impulse RC driver fixer?
Bardwell put out a video on fixing drivers, apparently a recent update has screwed PC’s again.
Last edited:


New member
Have you tried using a different SD card or formatting the current one? Sometimes that can solve the issue. As for the crashing on Velocidrone, it could be a compatibility problem with your system. Have you checked for any updates or patches for the game? Regarding your flight controllers not connecting to Betaflight, have you tried connecting them to your Ubuntu system to see if it works there? It's worth a shot! By the way, I'm new to this forum too, so let's help each other out. As for Windows 11, I'm not sure if there are any specific problems yet, but I can help you find a windows 11 pro retail key if you need one.
Last edited: