• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Retracts help?

#1
Hi yall, I got a Flexjet g2 from a friend, and I took out the aura 8 so I can put my own gyro in it, and I set up everything according to the manual, but the retracts won't move. When I connect the retracts to another receiver with no servos connected they retracts and the doors close. When I connect a servo to the port and flip the switch, it moves, but when I connect the retracts to the port, they don't do anything. Do any of yall have an idea of what the problem is? I even took out the bec from the esc, and put in a higher amp bec. I can change the voltage from 5 to 5.5 or 6 if I need to, but some of the servos say, "optimized for 5v". Would it be safe to try with 6v on the bec?
 

KN4IUU

Active member
#2
Hi yall, I got a Flexjet g2 from a friend, and I took out the aura 8 so I can put my own gyro in it, and I set up everything according to the manual, but the retracts won't move. When I connect the retracts to another receiver with no servos connected they retracts and the doors close. When I connect a servo to the port and flip the switch, it moves, but when I connect the retracts to the port, they don't do anything. Do any of yall have an idea of what the problem is? I even took out the bec from the esc, and put in a higher amp bec. I can change the voltage from 5 to 5.5 or 6 if I need to, but some of the servos say, "optimized for 5v". Would it be safe to try with 6v on the bec?
What gyro do you have in it?
 

Tench745

Elite member
#3
What brand of retracts and brand of receiver do you have? My electric retracts from Horizon will only actuate when they receive 0% or 100% signals from the transmitter. If, for whatever reason, your transmitter isn't sending high enough or low enough PWM signals to the retracts, they might not be actuating. I seem to recall that Spektrum transmitters output lesser PWM values at full throw than other brands of transmitter.
 
#4
Hi yall, I got a Flexjet g2 from a friend, and I took out the aura 8 so I can put my own gyro in it, and I set up everything according to the manual, but the retracts won't move. When I connect the retracts to another receiver with no servos connected they retracts and the doors close. When I connect a servo to the port and flip the switch, it moves, but when I connect the retracts to the port, they don't do anything. Do any of yall have an idea of what the problem is? I even took out the bec from the esc, and put in a higher amp bec. I can change the voltage from 5 to 5.5 or 6 if I need to, but some of the servos say, "optimized for 5v". Would it be safe to try with 6v on the bec?
The Aura is more than simply a gyro. I would the Aura back in to test the retracts.
 
#5
I don't have the gyro in yet, but I have a hobbyeagle gyro that I want to put into it. The retracts and sequencer are stock. The rx is an OrangeRx R1220X v2 and the tx is a Jr 9503. I tested the retracts when they were connected to the Aura 8, but they would not move, so I moved them to the rx, and then they worked. I ended up putting the throttle and retracts to the tx before taking the aura out because those two wouldn't respond to any inputs I gave, but they both worked when connected directly to the rx.