• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Rotor bones tricopter issue

mdr1031

Junior Member
#1
So looking for some help with an issue. I had the tri flying nice, but was using a cheap 9g servo and noticed it wasn't performing that well. So once the servo that was recommended in the parts list was in stock I got that put on. Now I can't get the tri to stop spinning. No matter how much I adjust it it won't dial in. Any suggestions would be greatly appreciated.
 

baddox

Senior Member
#2
Does it spin very quickly? Does it always spin in the same direction? Can you stop or slow down the spinning by yawing in the opposite direction? Have you tried resetting the settings on your transmitter or flight controller (I had the problem because I had accidentally added rudder mix to one of my other channels on my KK2 board)?
 

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#3
I think the solution is in the stick scaling option of the menu. You'll find the rudder setting at either "100" or "-100" Adjust that number to the opposite, and that will fix the problem.
 

earthsciteach

Moderator
Moderator
#4
I second Monkey's advice. The 100 vs -100 has to do with digital vs analog servos. If that doesn't do it, loosen your control rod connection to the servo, recenter and tighten.
 

kah00na

Senior Member
#6
Forth to Monkey and Teach and Mustang's 7302 recommendations. If it is a digital servo, you may also notice that it does not re-center on the ground until you stop the accelerator. Get it in the air and it should recenter fine. I guess digital servos need some kind of resistance on them to recenter correctly. When I replaced my analog servo with a digital one, it wouldn't recenter on the ground and after reading online about the tricopter having to be in the air, I tried to fly and it and sure enough, it re-centered just fine in the air. I'm not going back to analog servos if I can avoid it.
 

Cyberdactyl

Misfit Multirotor Monkey
#7
I have a Bluebird digital and a Bluebird analog that look exactly the same except for some small print on the digital saying so. I accidentally put the analog on and it flies fine. Haven't found the need to change it. Although I imagine the fidelity would improve a bit.
 

mdr1031

Junior Member
#8
Appreciate the tips! Didn't even think about the stick scaling for digital vs analog. Haven't had a chance to test it out; class just started back. I'll let you all know how it goes.
 

mdr1031

Junior Member
#10
Another quick question. I'm going to go home and test some different things tonight to see if any of them fix the new issue, but figured I might cut some of the trial and error down. In the mix folder I changed the rudder channel from +100 to -100, and that fixed the fast spinning problem that I was having. The issue I'm having now is when hovering I have to give a little right rudder to keep a straight heading, if i release the right rudder it starts to creep left. I'm pretty sure i have the servo centered and added a little right tilt. I'm using the prop layout that the kk2 board shows in the layout, so the front left and tail spinning cw and front right ccw. Wondering if it's not centered correctly and I need to add sub trim or something like that. Thanks again for any suggestions.
 
#11
Just a trim issue. Use the trim settings on your transmitter to offset the right rudder you manually give it. If it takes a lot of trim to fix, you might look at lessening the nuetral tilt you have. Looking from the rear of the copter, the tail tilting right will push with a left spin needing right rudder to counter act.