• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Servo is hot!

#1
Hello FT Forum, I am in serious trouble possibly. I crashed an airplane about 5 minutes ago, and a 5 gram servo I was using is seriously overheating. It MELTED the hot glue that it was attached to. Is it a fire hazard or anything? I immediately unplugged it from the aircraft. The motor was making the power up sound repeatedly and the reciever was going bananas. I shut everything down and haven't powered anything up again yet. image.jpg
 
#2
Now, I've powered the aircraft back up and I was able to put it back up in the air... before the wind forced an unplanned landing. I should probably explain: this is a payload release servo, so it's not the end of the world if I can't use it. The plane still flies without it. IMG_4019.JPG
I crashed into a fence in a knife edge, so possibly the shuttle pulled it loose.
 
#9
Well I'm not sure why the servo was going crazy but I just put it in a tester and it works fine. I think the crash tried to pry the shuttle loose and the servo just strained. It works fine now. I'll be careful and see what happens
 
#13
True, but that only happened after the crash. I tested it in a glide test earlier today and nothing happened. It works fine now. I won't risk it being plugged in and flying until further testing is complete
 
#15
I wont if its too dangerous. I appreciate all the suggestions and help that Ive received here. My immediate concern at the time was fire, but that seems to not be possible. If I use it again, it'll be the rudder servo in a 4 channel aircraft. I don't use the rudder too much in 4 channel.
 

Bricks

Well-known member
#16
Well I'm not sure why the servo was going crazy but I just put it in a tester and it works fine. I think the crash tried to pry the shuttle loose and the servo just strained. It works fine now. I'll be careful and see what happens
More then likely during the crash the servo got stalled and very well could be the reason it got hot and being stalled pulled way more voltage then the ESC could handle. Which could cause the rest of your servo`s going bonkers and receiver from low voltage.
 
#17
More then likely during the crash the servo got stalled and very well could be the reason it got hot and being stalled pulled way more voltage then the ESC could handle. Which could cause the rest of your servo`s going bonkers and receiver from low voltage.
So is the servo fine then? I was using a 12 amp ESC. Do I need to check that out?
 

Bricks

Well-known member
#18
So is the servo fine then? I was using a 12 amp ESC. Do I need to check that out?
ESC at 12 amps tells nothing how many amps the BEC puts out to the receiver usually that small of an ESC only puts out ! amp mmmaybe 2 a stalled servo can easily pull the voltage to low for the receiver to work and cause the rest of your servos to do all kinds of weird things. I would still keep an eye on it and use it in a non critical areas until it has earned your trust.
 
#19
Another possibility is a short in the wire connection to the board in the servo itself. If current was able to flow back through the data line to the receiver, it could be tripping a safety cutout in the receiver causing a reset, after the reset, the short is still there, current flows back to the data line, safety cutout again, and loop {while (current>0)}. Might want to test that servo again and move the wires around to see if you get the same result. It could also be dependent on temperature where the short only occurs when something heats up from normal use and then the short makes heat.

If you can replicate the error again, I'd throw the servo away and get a new one. If you can't replicate the error again, I'd throw the servo away and get a new one. If you decide not to test again, I'd throw the servo away and get a new one.