• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Spektrum DXe trim issues

#1
Hoping someone has run into this problem before and can save me some diagnostic time.
Scenario:
new DXe transmitter, set up using the spectrum program on iphone
Problem:
None of the trim switches are working. Cant say whether they worked before the "setup" or not since that was the first thing I did. I have eliminated the common "broken tab" as a culprit. Im hoping it was something done during setup since all switches were affected.
Question: is there a factory reset feature for the DXe? Ive done the Google dance and haven't found anything of use.
Thanks folks!
Ozzie
 
#2
I’ve had the exact same problem, except if you hold the trim every 3-5 second it still clicks. I haven’t tried to hard but I haven’t been able to fix it. Maybe that’s what I’ll do today, I’ll update if I figure it out.
 
#4
I got frustrated with it again:eek:, it’s really hard to keep the transmitter connected to the app so making changes is extremely difficult:( . Didn’t figure out the problem either, eventually the transmitter just quit connecting to the app. Have you realized that you can reverse servos in the transmitter? I found This a couple years ago