• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

TURNIGY TGY-I6 PROBLEM

#1
Hi great to meet all of you , got a problem with the aileron channel on my TGY-i6 the servo is not moving in time with the control stick i have tried new servo ,different receivers and moving ailerons to no 4 channels this fixes problem but use the no 1 channel for anything and it does the same thing not sure if problems mechanical ie the gimbal or is it the set up that is wrong appreciate any help on this matter
 

Merv

Well-known member
#2
Welcome to the forums
I'm not sure I have this correct. When you move the servo to channel 4, it will respond?
Is it responding to the aileron stick? Have you added a mix?

If this is correct, then there is nothing wrong with the aileron gimbal. The problem is somewhere else. Check the screen that shows the output of the sticks to see if all are responding.
 
#3
thanks for the reply yes you have got it correct also as I have 2 of this model transmitter I went through each transmitter and compared all settings and found the problem persists in one transmitter but not on the other although all settings are identical also returned the problem transmitter to factory settings with the same result but I will check out what you said as I found setting these type of transmitters up can be a challenge if like me you were used to slides switches and mechanical adjustments and you were used to setting the plane up to fly itself, again many thanks