• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

UR65 (crazybeef3DX) no binding the radio (spektrum receiver)

Good morning, is about three-day I'm trying to bind my ur65 with Spektrum module (crazybeef3DX) whit my radio.
The first time I tried to bind all works, but after 1 minute of fly, the drone disconnected from the radio.
After that, the drone refuses to connect to my radio. I put in the binding mode the drone, but when I set the binding mode of my radio, the drone stops binding and it doesn't go into bind complete status ( I think it refused to bind).
I'm so frustrated about that.
The procedure I follow is:
1) reset all parameter
2) calibrate the gyroscope
3) check the uart3 port is in serial_rx mode
4) save and reboot
5) set speksat into receiver mode tab
6) set spektrum2048 serial receiver provider tab
7) save and reboot
8) open CLI and write set spektrum_sat_bind_autoreset= OFF, set spektrum_sat_bind = 9 , save
9) after 10 seconds I put off the USB
10) after 1 second I reinsert the USB and it goes into the binding mode.
11) press binding on the radio.
12) When I press the button on the radio, the drone stop to flashing ( doesn't go into the complete binding mode, no solid led) .
13) Into the receiver tab no signal of the radio.

Thanks for your time.


Wake up! Time to fly!
Im gonna guess Betaflight 4.0 or later? This is a known issue Try flashing a pre 4.0 release and see if that gets you functional.
I first tried the latest version 4.0.6.
After that, I retried with the 3.5.7 (the first before 4.0.0 version).
In the end, I retried with the 3.5.3 but the problem persists.
Every time the same routine: It happens that the drone starts the binding mode but when I press the button on the radio, the drone stops the binding mode and It refuses that.


Eternal Student
There is no need to reset all your BF settings for each bind attempt, steps 1-7 only need to be done once. Make sure you have some decent separation between the Tx and Rx while binding - at least 3 feet.